WordPress.org

Ready to get started?Download WordPress

Forums

AdRotate
[resolved] Error Message Upon Plugin Activation (6 posts)

  1. tgbauer77
    Member
    Posted 3 years ago #

    Here is my error message:

    The plugin generated 54 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    I tried deleting and reinstalling/reactivating twice to no avail.

    This a great plugin, so any help you can provide to get this up and running would be great.

  2. stvwlf
    Member
    Posted 3 years ago #

    You only saw this once, during plugin activation, correct?

    Do you see it every time you load a page in the admin?

    Is the plugin working correctly?

    Most of the time this is a one time error during plugin activation. If the plugin is working as intended you can usually ignore that message.

    Its usually a small coding error by the plugin's author or possibly a small conflict with another already installed plugin.

    If you see it every time or the plugin doesn't work then yes its something that needs to be dealt with.

  3. lavieenrose
    Member
    Posted 3 years ago #

    I received the EXACT same message...

    what does this mean??

    I deactivated this until it's addressed.

  4. fotofio
    Member
    Posted 2 years ago #

    I've been developing a content slider for WP. Was working fine on 2.9.1, but when moved to current version of WP, it generates the same error message on activation --> The plugin generated 3 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    As stvwlf points out above, where the message does not persist (is a one-time error during activation only), and the plugin works as expected without generating any additional errors, it's probably ok to let it go.

    However, I did wish to share a new plugin with the WP community. As it is, I must supply a laughable caveat, but morevover, such will not fly for the vast majority of potential users, including myself.

    There has to be a sensible way to discover the cause. More suggestions please....

  5. fotofio
    Member
    Posted 2 years ago #

    Continued from above::::
    I have a fresh install of WP3.2.1 w/no other plugins activated, and only the default installation of theme/page/post/comment.

    By the way, I have a sneaking suspicion that the error is more MySQL than PHP.

    Have tried various file encodings: unix/utf-8, unix/utf-8 no BOM, unix/ansi

    checked all before and after whitespace <?php ?>

    checked folder/file permissions

    Wrapped the activation hook in a conditional:::::
    if (is_admin()) {
    register_activation_hook(__FILE__,'avoslider_plugin_install');
    }

  6. Arnan de Gans
    Member
    Posted 2 years ago #

    http://adrotateplugin.com/page/manuals.php read the 3rd issue/question

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags