WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Error message: The plugin does not have a valid header. (3 posts)

  1. 47songs
    Member
    Posted 3 years ago #

    The plugin is:
    Xtreme Banner Rotator AS3 by Flashtuning

    I have WordPress 3.1.

    I can upload the zip file, but cannot activate it. And it doesn't appear in my list of plugins afterwards.

    Any thoughts?

    Donna

  2. lifeisagame007
    Member
    Posted 3 years ago #

    Hi, I had the same problem with Simple Crumbs plugin.

    The problem was in the top lines of code of the simplecrumbs.php

    Originally it had an @ in front of every line so all I had to do was REMOVE @ from beginning of each line. See example below.

    Hope this will solve your problem as well.

    Original code
    /*
    @Plugin Name: Simple Crumbs
    @Description: Simple Crumbs - Generates a breadcrumb trail for pages and blog entries. Requires use of permalinks, and php > 4.1.0, tested WP 2.7
    @Note: link/crumb information from $query_string
    @Note: page/post information from $post
    @Note: using permalink info for making links
    @Note: using permalink structure for bootstrapping unrolled recursions (deepest to topmost)
    @Author: Can Koluman
    @Version: 0.2.5

    Change to
    /*
    Plugin Name: Simple Crumbs
    Description: Simple Crumbs - Generates a breadcrumb trail for pages and blog entries. Requires use of permalinks, and php > 4.1.0, tested WP 2.7
    Note: link/crumb information from $query_string
    Note: page/post information from $post
    Note: using permalink info for making links
    Note: using permalink structure for bootstrapping unrolled recursions (deepest to topmost)
    Author: Can Koluman
    Version: 0.2.5

  3. 47songs
    Member
    Posted 3 years ago #

    Thank you!

    My issue ended up being my mixup on which files went into which folders. I had originally uploaded the free program then bought the licenced version. There was a matter of some files that needed to be deleted and some that needed to be overwritten.

    Anyways, yesterday, after trying to get it to work for two days, I got the right folders into their correct folders and got it to work.

    This morning, I got a reply from the developer which told me basically to do things the way I did.

    But your response is very appreciated. Sometimes this stuff is complicated, and sometimes it's really simple. But if you don't know what you're doing, you don't know which one it is.

    Thanks!

    Donna

Topic Closed

This topic has been closed to new replies.

About this Topic