WordPress.org

Ready to get started?Download WordPress

Forums

error message: is_a(): Deprecated. Please use the instanceof operator (9 posts)

  1. Bodhipaksa
    Member
    Posted 4 years ago #

    I switched my hosting to FatCow the other week (please don't laugh) and so far it's gone well except when I tried to run the WordPress Database Backup plugin. This worked fine in my previous hosting but I'm now getting the error:

    The following errors were reported: is_a(): Deprecated. Please use the instanceof operator

    Anyone know what this means and what, if anything, I can do about it?

  2. Brandon Allen
    Member
    Posted 4 years ago #

    Two things. First, you're likely using PHP version between 5.0.0 and 5.3.0. The is_a() function is a PHP4 function that was deprecated in PHP version 5.0.0, but then brought back in 5.3.0. Second, you're also likely using an old version of the WordPress Database Backup plugin, as I couldn't find that function being used in the most recent version of the plugin.

  3. sbrsbr
    Member
    Posted 4 years ago #

    I get the same error when email back the backup actioned manually. The first scheduled backup to email address worked, but I'm waiting for the next schedule.

    Version of wp-db-backup 2.2.2

  4. Brandon Allen
    Member
    Posted 4 years ago #

    @sbrsbr In your case, you are most likely using a PHP version between 5.0.0 and 5.3.0, and an outdated version of WordPress. Just like with WordPress, "deprecated" means the function will still work as expected, but it's likely to be completely removed in the future. The error is more of a warning essentially telling you to stop using that function. As of wp-db-backup 2.2.2, the is_a() function is removed, for the reason I've stated above, so this is not your problem.

  5. Bodhipaksa
    Member
    Posted 4 years ago #

    Sorry about the long delay in replying -- for some reason I thought I'd already done so. You're absolutely correct about the version of php being used. Fatcow currently uses 5.2.5. They're about to upgrade to 5.2.12, and I understand that 5.3.0 is the next step up, so hopefully that will come soon.

    However I am using version 2.2.2 of the plugin. If the function is not in the plugin, then presumably it's one of the WordPress wp-include files that's triggering the problem. I guess I'll just have to wait until Fatcow upgrades. Serves me right for choosing cheapo hosting!

  6. Brandon Allen
    Member
    Posted 4 years ago #

    The problem is indeed with WP files, although I think this was somewhat fixed in WP 2.9. You might consider upgrading to 2.9.2 (current version as of writing this), and see if that fixes things. I don't use the plugin, so I can't say for sure, but the error most likely only shows when you're in the dashboard, so if you can live with that, and the plugin still does what it should, I would just try to ignore it. I still recommend updating to 2.9.2, but if you can't do that make sure you update to 2.8.6. There were some pretty important security fixes in both 2.8.5 an 2.8.6. Given the scope of the vulnerabilities fixed, I would say it's a matter of when, not if, your site gets hacked.

  7. Bodhipaksa
    Member
    Posted 4 years ago #

    I do have the latest version of WordPress and always keep it up to date, but I still get the same error message. The only manual or scheduled backup option that works is the one that saves the file to the server. It works, although of course I have to remember to go in to the server and download the file every week. Hopefully Fatcow will upgrade at some point.

  8. Brandon Allen
    Member
    Posted 4 years ago #

    Sorry about that. I was looking at what the version number the topic was for, but forgot to take into account the fact topic was started a while ago. If you're current you can forget what I said about getting hacked, as I've not read about any major vulnerabilities for the 2.9 branch.

    Do you have the WP_DEBUG constant set to true in your wp-config.php file. If so, you might set it to false and see if that helps. I'm not at all familiar with the wp-db-backup plugin to know if that would make a difference, but it's worth throwing out there. If you haven't already explicitly set it to true, there's no need to do anything, as it's false by default.

  9. Bodhipaksa
    Member
    Posted 4 years ago #

    Thanks for the suggestion. It was worth checking, but as it happens my wp-config file didn't have that code in it, so I guess it's defaulting to FALSE.

Topic Closed

This topic has been closed to new replies.

About this Topic