WordPress.org

Ready to get started?Download WordPress

Forums

JW Player for Flash & HTML5 Video
[resolved] Error loading player: No playable sources found (10 posts)

  1. jlc500k
    Member
    Posted 5 months ago #

    The player was working fine ever since I installed the plugin today and configured my playlist. Somehow it stopped working as I've spent the day working on different things on this site.
    I'm wondering if it's a permalink setting causing it to not play the direct file anymore?
    I can play the audio files without any issue in my Media Library. Any help would be greatly appreciated.

    http://spencermusic.com/music-samples/

    https://wordpress.org/plugins/jw-player-plugin-for-wordpress/

  2. JW Player
    Member
    Plugin Author

    Posted 5 months ago #

    What is the shortcode for this post? I don't see any video being loaded in the source of the page.

  3. jlc500k
    Member
    Posted 5 months ago #

    [jwplayer playlistid="1" player="0"]

  4. JW Player
    Member
    Plugin Author

    Posted 5 months ago #

    What is the source of that playlist item in the media manager?

  5. jlc500k
    Member
    Posted 5 months ago #

    The file URL is: http://spencermusic.com/wp-content/uploads/2014/03/OverInTheGloryLand.mp3

    The permalink is: http://spencermusic.com/music-samples/overinthegloryland/

    I'm thinking that somehow the playlist is pulling from the permalink and not the file URL??

  6. JW Player
    Member
    Plugin Author

    Posted 5 months ago #

    Yeah, that might be, as the permalink is just a page, not the actual mp3 file.

    I would try this shortcode:

    [jwplayer file="http://spencermusic.com/wp-content/uploads/2014/03/OverInTheGloryLand.mp3" player="0"]

  7. jlc500k
    Member
    Posted 5 months ago #

    I'm curious as to what happened. As I mentioned earlier, the player was working wonderfully with the playlist I had created. Something must have happened while I was configuring the rest of the site to change the playlist location, or something to cause it not to work right.

    Regardless, how can I tell where the actual playlist file is located, so that the entire playlist is playing, not just a single song like you have in the shortcode above? Is there a way to link directly to the XML file?

    I even tried deleting an audio or two, creating a new playlist, re-uploaded the songs, but to no avail. It still shows the same error message. I even tried deactivating the JW plugin and reactivating it, along with deactivating all of my plugins and leaving JW Plugin activated. Nothing I've tried has made a difference, it still says "No playable sources found."

  8. JW Player
    Member
    Plugin Author

    Posted 5 months ago #

    You can make an XML file and then do - [jwplayer playlist="yourplaylist.xml"]

  9. jlc500k
    Member
    Posted 5 months ago #

    I think I figured it out...

    I went to the page where I had the shortcode embedded, and deleted the shortcode. From there, I clicked on "Add Media" selected "Insert JWP Playlist", selected my playlist and clicked on "Insert this player into your post."

    Everything is working normally again.

    For whatever reason, my playlist ID changed from "1" to something else which was causing the playlist not to load correctly. Weird

    Thanks for your help regardless.

  10. JW Player
    Member
    Plugin Author

    Posted 5 months ago #

    Great, glad you got it, np.

Reply

You must log in to post.

About this Plugin

About this Topic