WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] ERROR - incomplete headers (4 posts)

  1. jabecker
    Member
    Posted 7 years ago #

    After upgrading to 2.1, I'm seeing this error:

    [error] FastCGI: incomplete headers (0 bytes) received from server "/usr/local/www/fcgi-sys/php-fcgi"

    I have:
    -- completely reinstalled 2.1
    -- completely revamped my theme
    -- checked all of the core file, plugin files and theme files for spaces at the beginning and end and removed same

    I'm willing to dig in and get my hands dirty, but I'm not a developer and what I've tried already is about the limit of my know how.

    Is there anyone who can help me with this or has any suggestions?

    Thanks!

  2. jabecker
    Member
    Posted 7 years ago #

    Finally figured it out so I'll post the resolution in case anyone else needs the fix (or I need it again).

    In Options >> Reading
    Make sure that the button "WordPress should compress articles (gzip) if browsers ask for them" is NOT selected.

  3. AskApache
    Member
    Posted 7 years ago #

    This was happening to me as well and I think that its happening because my host deletes the session files for fast-cgi out of /tmp, or because of process management that kills processes after a certain time, or restrictions placed on how many processes your script can run until it gets denied and you see 500 errors.

    FastCGI Problems and Solutions

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Dreamhost = endless problems. I would avoid them.

    Same goes for FastCGI in general.

Topic Closed

This topic has been closed to new replies.

About this Topic