WordPress.org

Ready to get started?Download WordPress

Forums

AmazonSimpleAdmin
Error in Server Log Every Second (4 posts)

  1. aktionj33
    Member
    Posted 1 year ago #

    I am getting the below error every second on my server logs. I am novice so this may as well be a foreign language. Can anyone offer any fix to clean out my server logs?

    /wp-admin/error_log:
    #3 /wp-content/plugins/amazonsimpleadmin/AsaCustomerReviews.php(55): AsaCustomerReviews->_grabReview()
    #4 /wp-content/plugins/amazonsimpleadmin/AsaCore.php(1660): AsaCustomerReviews->__construct( in /wp-content/plugins/amazonsimpleadmin/lib/AsaZend/Http/Client/Adapter/Socket.php on line 235PHP Fatal error:  Uncaught exception 'AsaZend_Http_Client_Adapter_Exception' with message 'Unable to Connect to tcp://www.amazon.com:80. Error #0: php_network_getaddresses: getaddrinfo failed: Name or service not known' in /wp-content/plugins/amazonsimpleadmin/lib/AsaZend/Http/Client/Adapter/Socket.php:235
    Stack trace:
    #0 /wp-content/plugins/amazonsimpleadmin/lib/AsaZend/Http/Client.php(973): AsaZend_Http_Client_Adapter_Socket->connect('www.amazon.com', 80, false)
    #1 /wp-content/plugins/amazonsimpleadmin/AsaCustomerReviews.php(131): AsaZend_Http_Client->request('GET')
    #2 /wp-content/plugins/amazonsimpleadmin/AsaCustomerReviews.php(82): AsaCustomerReviews->_getIframeContents()
    #3/wp-content/plugins/amazonsimpleadmin/AsaCustomerReviews.php(55): AsaCustomerReviews->_grabReview()
    #4 /wp-content/plugins/amazonsimpleadmin/AsaCore.php(1660): AsaCustomerReviews->__construct( in /home2/doityov6/public_html/wp-content/plugins/amazonsimpleadmin/lib/AsaZend/Http/Client/Adapter/Socket.php on line 235

    My Site: http://www.DoItYourselfRV.com
    http://wordpress.org/extend/plugins/amazonsimpleadmin/

  2. Timo Reith
    Member
    Plugin Author

    Posted 1 year ago #

    Seems like your server can't connect to the amazon webservice. You should ask your hoster to allow that.

  3. aktionj33
    Member
    Posted 1 year ago #

    Hi Timo,

    Thank you very much for replying. I think your plugin is great, I just hate to see these constant errors. I went ahead and contacted my host about it and here was the response:

    If they could give us details about the sequence of things that need to happen to use the amazon web servicewe may be able to help further. I can tell you based on a curl to amazon.com that simply accessing amazon.com works
    curl http://www.amazon.com
    brings up the contents of their front page.

    which is what the exception says that its trying to do when it says that its trying to make a tcp:// connection to http://www.amazon.com on port 80

    but it may be trying to do something else (web service) related then it gets there, which may be what is actually failing.

    This is the section of that plugin that makes a connection to the amazon service (and normally probably connects to something more involved than retrieving the front page). It gives the option to connect to particular ports,
    /wp-content/plugins/amazonsimpleadmin/AsaCore.php(2345): AsaCustomerReviews->__construct('B0028W4P18', 'http://www.amaz...', Object(AsaZen in /wp-content/plugins/amazonsimpleadmin/lib/AsaZend/Http/Client/Adapter/Socket.php on line 235

    What ports does it need to connect on? If it is something more than port 80 there may be a block on the firewall.

    Thank you,
    Jason
    Level II Site/Script Compatibility
    BlueHost.com
    888.401.4678

    When you find the time could you try to sort through this? I am sure other folks on shared hosting may benefit.

    Thanks!

  4. Timo Reith
    Member
    Plugin Author

    Posted 1 year ago #

    The mentioned section does not connect to the webservice but to the customer ratings page. But regardless, the plugin only makes connections on port 80. For the webservice on host tcp://ecs.amazonaws.de and for the customer ratings page on host tcp://www.amazon.de.

    In the initial error message it says: "Unable to Connect to tcp://www.amazon.com:80"
    That means, the server can not connect to tcp://www.amazon.com on port 80 and that's the problem.

    If you google for the PHP error "php_network_getaddresses: getaddrinfo failed: Name or service not known" you will find something like this:
    http://stackoverflow.com/questions/8210099/php-php-network-getaddresses-getaddrinfo-failed-no-such-host-is-known
    what suggests that it is an issue of server configuration.

    If it would be a general problem/bug, every user of the plugin would have this error.

    If your hoster thinks something else gets blocked by the firewall, I think it would be best if they look into their firewall logs and check out what it is, because I can not imagine what it could be. The above mentioned hosts on port 80 are the only connections the plugin requests.

    I hope we can solve this...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.