WordPress.org

Ready to get started?Download WordPress

Forums

Error in Permalinks (4 posts)

  1. pianodude363
    Member
    Posted 5 years ago #

    Hello

    I just upgraded to WordPress version 2.6 from 2.5.2 and I now get the error:

    Warning: fopen(/home/literate/public_html/index.php/.htaccess) [function.fopen]: failed to open stream: Not a directory in /home/literate/public_html/wp-admin/includes/misc.php on line 45
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/literate/public_html/wp-admin/includes/misc.php on line 70
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/literate/public_html/wp-admin/includes/misc.php on line 72
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/literate/public_html/wp-admin/includes/misc.php on line 72
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/literate/public_html/wp-admin/includes/misc.php on line 72
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/literate/public_html/wp-admin/includes/misc.php on line 72
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/literate/public_html/wp-admin/includes/misc.php on line 72
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/literate/public_html/wp-admin/includes/misc.php on line 72
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/literate/public_html/wp-admin/includes/misc.php on line 72
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/literate/public_html/wp-admin/includes/misc.php on line 72
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/literate/public_html/wp-admin/includes/misc.php on line 73
    
    Warning: fclose(): supplied argument is not a valid stream resource in /home/literate/public_html/wp-admin/includes/misc.php on line 75

    Also... when I go to a permalinked page, I get the error...

    No input file specified.

    Thanks for the help!

  2. pianodude363
    Member
    Posted 5 years ago #

    This is very strange. I can no longer login to my control panel because every time i try to login i get redirected back to the login screen. I know my password is correct.

  3. pianodude363
    Member
    Posted 5 years ago #

    I just changed my permalink structure back to the default ugly style, and everything works fine. However, when I try to get it into this format: /%year%/%monthnum%/%day%/%postname%/, i get the above error. What can I do to make it so that this kind of permalinks work. One thing to note is that I did have wp-united installed a long time ago, but i think i fully uninstalled it.

    One thing i am noticing though, is that all of my URLs redirect to the main url/index.php/article name for about 1 second before refreshing to the real URL.

  4. pianodude363
    Member
    Posted 5 years ago #

    fixed it myself - turns out that my blog URL was set to myurl.com/index.php and that was messing things up.

Topic Closed

This topic has been closed to new replies.

About this Topic