WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Error Establishing database connection (9 posts)

  1. RRTeam
    Member
    Posted 5 years ago #

    Hi, i finally figured out how to upload the template files to my server, i have a mac, so i needed to use filezilla...phew...

    so, now that its uploaded, i installed into a file in the root (not sure if i did that right or if i should have saved it directly into root?)

    Anyhow i go to this link to install and get error:

    http://www.bedford-ny-real-estate.com/root/wordpress/wp-admin/install.php

    I am using start logic.

    Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at rrteam.startlogicmysql.com. This could mean your host's database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

    here is the info from the config file: ( *'s for protection)

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'bedfordnyrealestate'); // The name of the database
    define('DB_USER', 'rrteam'); // Your MySQL username
    define('DB_PASSWORD', '*******'); // ...and password
    define('DB_HOST', 'rrteam.startlogicmysql.com'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    // Change SECRET_KEY to a unique phrase. You won't have to remember it later,
    // so make it long and complicated. You can visit http://api.wordpress.org/secret-key/1.0/
    // to get a secret key generated for you, or just make something up.
    define('SECRET_KEY', '*********'); // Change this to a unique phrase.

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_1'; // Only numbers, letters, and underscores please!

    (i did change this to wp_1 - not sure if that is ok or what i should change to??)

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');

    Thanks for any help!
    ?>

  2. RRTeam
    Member
    Posted 5 years ago #

    Ok, i reset my password, and that did the trick.

    Now, how do i get my blog come up under my website domain?

    (ie: i want the site to come up under http://www.bedford-ny-real-estate.com
    NOT http://www.bedford-ny-real-estate.com/root/wordpress)

    Do i need to move the files? I thought putting them under root would do the trick.

    I want to use this as a website, not a blog, by the way (i want to have a blog and website).

  3. MichaelH
    Member
    Posted 5 years ago #

    If you created a root folder that could be your problem. Typically you don't need to create your web-root folder as your host will create that for you--you just need to know what is your web-root folder. In your case it looks like your web-root folder is the folder where you created the "root" folder.

    To make WordPress available at http://www.bedford-ny-real-estate.com I'd upload the wordpress folder into your web-root folder. Then I'd install WordPress by browsing to http://www.bedford-ny-real-estate.com/wordpress. Then after installation I'd login and change in Settings->General, the Blog address (URL) to http://www.bedford-ny-real-estate.com and put this index.php file in your web-root folder (it is the same folder that contains the wordpress folder)

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wordpress/wp-blog-header.php');
    ?>

    Since you just installed make sure you DROP your database tables before starting the process I recommended. Of course you will ultimately delete the web-root/root/wordpress folder.

  4. RRTeam
    Member
    Posted 5 years ago #

    Well, in my Filemanager, I have the following folders (i only made the 1 for wordpress)
    Home, public_html, cgi-bin ,root, wordpress, Home.html, stats

    The wordpress file is under public_html/root

    thoughts?

  5. MichaelH
    Member
    Posted 5 years ago #

    There should be no public_html/root folder. DELETE it.

    Put the wordpress folder in the public_html folder. Remember, public_html is your web-root folder.

    Please reread all my comments above!!!!

  6. RRTeam
    Member
    Posted 5 years ago #

    Hi, i moved wordpress to public_html, and deleted root, but now, when i try to log in it looks funny (template is messed up) http://www.bedford-ny-real-estate.com/wordpress/

    and when i try to log in, it says: Page not found

    thanks for any help.

  7. RRTeam
    Member
    Posted 5 years ago #

    what can i do? I cant log in... i tried deleting wordpress from the server and reinstalling it directly to public_html and still cant log in? help please! thanks!

  8. MichaelH
    Member
    Posted 5 years ago #

    If you are using the same database as that first installation, meaning when you moved the files you didn't reinstall, then you may need to fix your WordPress and Blog addresses.

    See: http://www.tamba2.org.uk/wordpress/site-url/

  9. RRTeam
    Member
    Posted 5 years ago #

    Thanks! its fixed :) You rock! Now to figure out how to upload a template! lol

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.