WordPress.org

Ready to get started?Download WordPress

Forums

Error establishing database connection (15 posts)

  1. nysrpa
    Member
    Posted 9 years ago #

    I'm getting this error message at the ../wp-admin/install.php screen. I'm sure I put in the correct DB, username, password, and localhost.

    My host runs MySQL 3.23.49. I create the database called "wordpress" with phpmyadmin 2.5.0 and a user called "wordpress". The user has no global privleges and all privleges for the database "wordpress".

    Help!

  2. gnukerman
    Member
    Posted 9 years ago #

    This may not be of much help, but it could be your host.

    I can't find the post, but I saw a similar problem last week and it turned out the person was using godaddy.com as a host and their sql wasn't localhost but something like mysql.localhost.server.

    Check with your host to see what the correct sql server is if indeed localhost is causing the problem.

    Or perhaps someone else in this support group can offer some aid.

    Hope this helps a bit.

  3. gnukerman
    Member
    Posted 9 years ago #

  4. nysrpa
    Member
    Posted 9 years ago #

    I use Yahoo small business for hosting. I found I had to change localhost to mysql. it seems to be working ok now. Thanks.

  5. gnukerman
    Member
    Posted 8 years ago #

    Kewl

  6. PK_
    Member
    Posted 8 years ago #

    i'm new to wordpress. planning to migrate from blogger.

    i've subscribed to yahoo small business, the standard hosting package.

    i dont know how to start.

    i have opened an mysql database at yahoo. i have installed phpmyadmin at a subdirectory (unable to install it at the root!). i have downloaded the wordpress 1.5.1 and uploaded it to the root directory. i'm not sure how to configure the wh-config.php. at DB_NAME, DB_USER, DB_PASSWORD, i have entered the same info as i use in opening the mysql database with yahoo. at DB_HOST, i have tried both "local" and "mysql". but when i go to wp-admin/install, i got a blank page. what should i do?

    (i have tried removing the phpmyadmin while keeping wordpress, or uploading wordpress to the same directory with the mysqladmin, but all to no avail!)

    pls kindly help me.

    also, i dont know what to put at define ('WPLANG', ''); i do not need chinese userinterface, but i would write in english as well as chinese.

    tks a lot.

  7. moshu
    Member
    Posted 8 years ago #

    Whoa... man, you mean for $20 per month there is no phpMyadmin or any other DB management tool? That sucks :(
    If the databse is on the same server you should try "localhost" not local!
    mysqladmin is NOT the database, it's just a tool - it doesn't have to be in the same directory as WP.
    WHat does it mean you "opened a mysql at yahoo"? You mean you created a database? If yes, put the user and the passwrod from there into the config file.
    Don't worry about the WPLANG... you can write in Chinese even with English interface.

  8. PK_
    Member
    Posted 8 years ago #

    > you mean for $20 per month there is no phpMyadmin or any
    > other DB management tool?

    there IS. pphmyadmin is installed by yahoo at the same time i opened a mysql database.

    > you should try "localhost" not local!

    sorry abt the typo; i meant i had tried "localhost".

    > put the user and the passwrod from there into the config file.

    as i said, i did. but to no avail. blank page is returned.

    > Don't worry about the WPLANG... you can write in Chinese even
    > with English interface.

    great. thanks a lot.

  9. moshu
    Member
    Posted 8 years ago #

    I am more and more confused. In your initial post you mentioned 2 (two) MySQL tools - phpMyadmin and mysqladmin - saying you installed and uninstalled them...
    Usually on a hosted environment you do NOT install and uninstall them in any directory, they are there, because the host offers those tools for administering your database.
    Let's get back to the basics: read the Installing WordPress from the Codex and follow it step by step.
    If it doesn't work, post back.

  10. PK_
    Member
    Posted 8 years ago #

    tks again for ur reply.

    http://codex.wordpress.org/Installing_WordPress
    i have read this.

    actually, it's been just one tool, "phpsqladmin". "mysqladmin" was my wrong spelling. sorry. (but i wonder why u got back on this, as u had already advised that it's just a database tool (which i know actually) and has nothing to do with where the WP files are located.)

    u r right with the word "usually". in the case of yahoo small business, there IS an installation process, where, as a user says yes, yahoo puts the phpsqladmin in a directory the user creates.

    tks again.

    hope to hear from users who r using yahoo small business as the host.

  11. PK_
    Member
    Posted 8 years ago #

    if whether phpsqladmin is there and where it is are irrelevant, may i sum up what i have done at yahoo small business:

    i have created an mysql database with a database name, a username and a password

    i have uploaded the WP files to the root directory

    i have configured the wh-config.php in a way at DB_NAME, DB_USER and DB_PASSWORD i have used the same info as that i used in creating the mysql database.

    at DB_HOST, i have put "mysql", when going to wp-admin/install, it returned a blank page. i have also put "localhost", same!

    i'm looking for other ways to try, especially from current users of yahoo small business.

    tks a lot!

  12. moshu
    Member
    Posted 8 years ago #

    You may ask Yahoo or read their instructions for the database address... (some hosts have very specific addresses)

  13. PK_
    Member
    Posted 8 years ago #

    tks again. will consult yahoo at the same time. hope they wont say it's WP problem not theirs!

    all of a sudden i'm wondering if it's anything related to the file format i chose in uploaing the files via FTP

    i use fetch on mac. for file format i chose "automatic". should i have specified any one of the following instead?
    - text
    - raw data
    - mac binary iii
    - binhex
    - apple single

  14. Duncan_Feldane
    Member
    Posted 8 years ago #

    I'm having the same problem.
    Yahoo says the db is running.
    phpMyAdmin is ... "inscrutable" is the nicest term I can use.
    Tried various versions of this:
    // ** MySQL settings ** //
    define('DB_NAME', 'mysql'); // The name of the database
    define('DB_USER', 'admin'); // Your MySQL username
    define('DB_PASSWORD', '******'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    Also tried changing db_host 'localhost' into 'mysql'

  15. James
    Happiness Engineer
    Posted 8 years ago #

    Did you actually create a database called "mysql" with user "admin"? With such a universal DB host as "mysql" (which is what it should be), I seriously doubt that the database name "mysql" was available (not already in use).

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.