WordPress.org

Ready to get started?Download WordPress

Forums

Error establishing a database connection (goDaddy) (8 posts)

  1. dbrenton
    Member
    Posted 7 years ago #

    http://www.eclipsethem.com/wordpress/wp-admin/install.php

    ---------
    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at h41mysql7.secureserver.net. This could mean your host's database server is down.

    Are you sure you have the correct username and password? YES!!

    Are you sure that you have typed the correct hostname? YES!!!

    Are you sure that the database server is running? YES!!!
    --------

    PLEASE HELP ME!!! :-(
    This can't possibly be this hard.

    It has to be something with the hostname...i'm sure of it.

    I called go daddy & they said it was a wordpress problem.

    please help.

    thanks,
    dbrenton

  2. vkaryl
    Member
    Posted 7 years ago #

    Suggest a search for godaddy database here. There may be as many as 200 topics regarding this problem in the last couple of years. There will be info in some of them about what to do to fix it....

    It's btw NOT a wp problem - it's something to do with the way godaddy sets up the database name (I think, from what little I remember about a few of those threads - I don't use them at all....)

  3. dbrenton
    Member
    Posted 7 years ago #

    i've tried everything. i even called godaddy twice.

    db

  4. vkaryl
    Member
    Posted 7 years ago #

    Try calling them again and insisting the initial "tech" pass you along immediately to a second-tier tech.

    The only possible thing is that you've entered something in the config.php file that's not right. And the only real way to determine what that is is to get the right info from your tech support. If they aren't capable of doing that, then you might like to consider a better host.

    [Here's a new link to a tutorial for setting up on godaddy.]

  5. possum
    Member
    Posted 7 years ago #

    With godaddy you have to set to msql**.secureserver.net not local host

  6. Doodlebee
    Member
    Posted 7 years ago #

    Looks like it's connected just fine to me - just waiting for the first step to be initialized.

  7. dothage
    Member
    Posted 6 years ago #

    I have this same problem. I checked out the tutorial linked to above, but the problem begins where it says "Click on the name of the database you just set up." The database name is not clickable!

  8. dothage
    Member
    Posted 6 years ago #

    I've resolved this problem for my website. Just replace "local host" with the TCP/IP address of your database. For example, 10.3.51.982. You find this information by going to Databases, and then Manage Database for the database you're using. Once in the database manager, click on Advanced Configuration. That's where the TCP/IP address is for that database. If you create more than one, they'll have different addresses.

    Then you'll have to run install, and your admin password will be emailed to you.

Topic Closed

This topic has been closed to new replies.

About this Topic