WordPress.org

Ready to get started?Download WordPress

Forums

Error establishing a database connection (3 posts)

  1. Kiwizoom
    Member
    Posted 1 year ago #

    Never hooked up wordpress before but spent a considerable amount of time troubleshooting.

    Setting it up on localhost, windows XP, using latest XAMP as of September 2012 with MYSQL 6.5.4 and PHPMyAdmin and stuff.

    In the htdocs in XAMP I have my website folder, and the files in it are all accessible. However, I've tried to put the wordpress folder in htdocs, mywebsite, etc a couple different locations just to access the wp-admin install file. It seems while I can access all my other website files, it doesn't matter where this wordpress folder is I get a database error trying to access anything inside (including index, for example.) The install does not work which is the main bad thing going on.

    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?

    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

    I've checked my config file a lot and made the passwords correct; and, even resorted to killing passwords to just get this stuff accessible. I'm pretty sure I have my info right..
    What's gone wrong?

  2. lucentx
    Member
    Posted 1 year ago #

    Can you post the contents of your wp-config.php so we can have a better look at it?

  3. jhancock1000
    Member
    Posted 1 year ago #

    I'm having the same problem. But I installed WordPress with Microsoft WebMatrix as a local host a few days ago and it was working perfectly. Until today. I get the same error as the original poster if I try to access my WordPress admin at http://localhost:16290/wp-admin/.

    Here's the contents of my wp-config.php

    <?php
    /**
     * The base configurations of the WordPress.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'wordpress204');
    
    /** MySQL database username */
    define('DB_USER', 'wordpressuser204');
    
    /** MySQL database password */
    define('DB_PASSWORD', 'ig6_KTHbb_1R');
    
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         'put your unique phrase here');
    define('SECURE_AUTH_KEY',  'put your unique phrase here');
    define('LOGGED_IN_KEY',    'put your unique phrase here');
    define('NONCE_KEY',        'put your unique phrase here');
    define('AUTH_SALT',        'put your unique phrase here');
    define('SECURE_AUTH_SALT', 'put your unique phrase here');
    define('LOGGED_IN_SALT',   'put your unique phrase here');
    define('NONCE_SALT',       'put your unique phrase here');
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress. A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
     * language support.
     */
    define('WPLANG', '');
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    I'd really appreciate any help.

    I just want to reiterate that everything was working perfectly yesterday.

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic