WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Error establishing a database connection (6 posts)

  1. Tim
    Member
    Posted 1 year ago #

    I have wordpress v 3.1.3 that i downloaded a while back and im now trying to install it on my server to create a blog page for an existing site.

    the site is hosted on godaddy,
    i tried installing the latest stable version of wp but my godaddy (or at least my hosting package) is still running php 4.
    i thought it would be easier and save time to install an older version of wp.

    i created the database, uploaded all the files, but when i try going to the url to go through the installation process, all i get is "Error establishing a database connection"

    ive never used wordpress before in my life.
    anybody know what the issue might be?

  2. govpatel
    Member
    Posted 1 year ago #

    Go Daddy use some sort of url instead of localhost so check if you right info for your database in wp-config.php file

  3. RichardWPG
    Member
    Posted 1 year ago #

    - First, try contacting the hosting provider if the database server is online / if they have any other problem at their end, or they made any changes to your account, or if there are any limitations/restrictions, if the hosting package is set to Windows and not Linux, etc .
    - double check your wp-config.php file settings for the database name, database username and database password. This is where most errors occur. -Then check that you don't need to change the database host from "localhost" to something else. You can get that info from your hosting provider.
    -Check you have actually created a database with the same database name as is in your wp-config.php file.
    -Last, but not least, if all that information is correct your database probably has a problem with it, and you may need to contact your hosting provider.

  4. Mohsin Patel
    Member
    Posted 1 year ago #

    you have to changes values in wp-config.php

    dbuser,dbname and your database host string.

    That is the only issue - for Error establishing a database connection

    Hope that resolve your issue.

  5. Tim
    Member
    Posted 1 year ago #

    govpatel, and mohsince,

    Thank you very much.
    the issue was name, password, and host name in the config file.

  6. Tim
    Member
    Posted 1 year ago #

    im actually kinda surprised you have to set that info int he config file. the Drupal CMS gives you a login screen that asks for that info and auto updates the config.

Topic Closed

This topic has been closed to new replies.

About this Topic