WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Error establishing a database connection (10 posts)

  1. pawriter
    Member
    Posted 2 years ago #

    Wndows XP (SP3) 332 bit local installation of WordPress 3.2.1 on XAMPP 1.7.4 web server.

    As with many others I have struck this 'Error establishing a data base connection' error repeatedly when trying to complete my WordPress installation.

    I have now downloaded the WordPress 3.2.1.zip four times, each of the last 3 times I have completely replaced all subdirectories then extracted the core files for WordPress again. I have then renamed the wp-config-sample.php file to wp-config.php and edited it to include the appropriate entries. As soon as I run the instal script I get the error.

    I have tried 2 different text editors to make changes to the wp-config.php file.

    I have double checked the databasename, username and password for the MySQL database and the hostname (localhost) is correct.

    I have not yet found another thread in this forum that has been unresolved beyond this point.

    The only thing I have not yet tried (that I can think of) is to delete my wordpress MySQL user and the database and recreated them.

    I dont understand why doing so should make a difference but I will try that next unless someone else has a better suggestion.

  2. nsathees
    Member
    Posted 2 years ago #

    Have you started the mySQL server? Can do that from XAMPP control center.

    since you can create database, I assume that the MySQL is running. Try using the user as root and the respective password.

  3. pawriter
    Member
    Posted 2 years ago #

    Thanks!
    The MySQL server is certainly running according to the XAMPP control centre and I can access my Moodle database satisfactorily.

    Are you suggesting I install WordPress using the root user rather than the user I have created?
    If so I assume I change the username in the wp-config.php file to 'root' and leave the password blank.

    I do notice that the host for my 'wordpress' username is % but I assumed (from the instructions) that the correct hostname in the wp-config.php file is still 'localhost'

    What are the consequences of choosing 'root' as the user?
    Does this mean I shall have to do everything in WordPress as 'root'?

  4. ezhikorn
    Member
    Posted 2 years ago #

    I have exactly the same issue, with a fresh download of wp package.
    The db I have created for wp is ok from phpmyadmin and from mysql console.
    I have tried the root tip with the same result.

  5. ezhikorn
    Member
    Posted 2 years ago #

    That's it : the user has to be local, in phpmyadmin, user privedges, select "local", and it works !

  6. pawriter
    Member
    Posted 2 years ago #

    Thank you!
    That does work.
    I have spent three days learning a few 'extra' things along the way.

    I shall now review the WordPress instructions to see if I missed it.

    Once again thank you very much.

    I now have two users with the same name but at least WordPress is now installed.

  7. Nikhil Chaudhari
    Member
    Posted 2 years ago #

    I have downloaded the wordpress and at the final stage of installation on my windows 7 32 bit i see a window "Enter application information" and in the same window i am being as to either create a database/use current database option. As im a complete novice to the stuff iam not able to complete the installation. Kindly guide me as to what details i should add to Database administrator, database server, database name.

  8. ezhikorn
    Member
    Posted 2 years ago #

    the simpler, as a prerequisite of the wordpress install, is to install WAMPServer because there is all what you need : apache HTTP web serveur, PHP and MySQL. Once you have installed WAMPServer, you go to phpmyadmin (web interface to mysql written in php) to create a database and add a user with all priviledges on this DB. this is the place where you setup the user as "local". then you report these information : the dababase name, the user and the password in the WP setup.

  9. Nikhil Chaudhari
    Member
    Posted 2 years ago #

    I have installed 5 minute install version for windows which didnt mention any such prerequisite. I would appreciate if im given the links to above mentioned solutions as i wont be able to install a thing as i m doing this stuff for first time without any information of the terms used here

  10. Nikhil Chaudhari
    Member
    Posted 2 years ago #

    Please check this link on this very same site which explains my problem
    http://wordpress.org/support/topic/using-microsoft-web-platform-installer-30?replies=4#post-2371535

    Kindly help

Topic Closed

This topic has been closed to new replies.

About this Topic