WordPress.org

Ready to get started?Download WordPress

Forums

Error establishing a database connection (9 posts)

  1. koolshopper
    Member
    Posted 2 years ago #

    I DID create an empty MySQL database
    I DID create a user name and a password
    I DID modify those items in the wp-config.php file

    So why does it say it can't connect?

  2. ClaytonJames
    Member
    Posted 2 years ago #

    Either one of the following is incorrect:

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'putyourdbnamehere');
    
    /** MySQL database username */
    define('DB_USER', 'usernamehere');
    
    /** MySQL database password */
    define('DB_PASSWORD', 'yourpasswordhere');
    
    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    Or there is an issue with the MySQL server that is preventing a connection.

  3. koolshopper
    Member
    Posted 2 years ago #

    I created the database myself as koolshop_wp_forum
    I created the database username myself as koolshop_kool
    I created the database password as well and know it is accurate.

    I assigned the user full control of the database.

    The localhost setting should work, but if it doesn't should I try the name of the site's root as the host?

    Is there anythying else I should try?

  4. ClaytonJames
    Member
    Posted 2 years ago #

    You may want to check in with your host and verify that the hostname is correct. Sometimes they require something other than localhost.

    Some examples: Set Database Host

  5. koolshopper
    Member
    Posted 2 years ago #

    My host is running Cpanel so it most likely is localhost accordoing to the link above. I've had it set uo before when I was hosting with GoDaddy, but their installation script automated everything after I created the database settings.

  6. ClaytonJames
    Member
    Posted 2 years ago #

    If you have confirmed with your host - by contacting them or checking their FAQ - that "localhost" is the correct MySQL hostname, and all other information in wp-config.php is exact and correct. I'm afraid I'm at a loss for an answer.

  7. koolshopper
    Member
    Posted 2 years ago #

    I was afraid of that. For some strange reason it doesn't even recognize that the settings SHOULD ve accurate. The only other ting I can think of is to delete the wp-config.php file in an attempt to run the setup-config.php script. But when I've tried that, it says it's still there, even though I can clearly see it has been deleted off the remote server.

  8. HayManMarc
    Member
    Posted 2 years ago #

    I am having the same problem.

    When I go to http://www.....install.php I get this weird error:

    Warning: require(/home/(user)/public_html/wordpress/wp-includes/default-constants.php) [function.require]: failed to open stream: No such file or directory in /home/(user)/public_html/wordpress/wp-settings.php on line 22

    Fatal error: require() [function.require]: Failed opening required '/home/(user)/public_html/wordpress/wp-includes/default-constants.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/(user)/public_html/wordpress/wp-settings.php on line 22

    If I figure it out, I'll post again.

  9. HayManMarc
    Member
    Posted 2 years ago #

    I ended up re-installing wordpress into my root right over the top of the old one. I deleted the wp-config-sample.php file that was re-installed. All other files remained fine.

    I was able to access my dashboard afterwards. Blog seems to be working fine.

Topic Closed

This topic has been closed to new replies.

About this Topic