WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Error establishing a database connection (18 posts)

  1. lutor
    Member
    Posted 4 years ago #

    Hi there!...I'm trying to install WP offline and I'm using wampserver to create a database. I followed all the instructions and, at last, when I type on the browser http://localhost/whatever/wp-admin/install.php then appears this message on the screen. Username and password are correct, and hostname also (It's local!) But I can't understand the third condition very well. How Can I ensure if my database is running?. Thanx a lot folks, and please excuse my english...I'm from Spain...Thanks again.

  2. rizman
    Member
    Posted 4 years ago #

    Can you please give the message you are seeing? We can't access your local machine from here to see it.

  3. Samuel B
    moderator
    Posted 4 years ago #

    wamp is a huge pain
    this works every time for me
    http://www.tamba2.org.uk/wordpress/xampp/

  4. rizman
    Member
    Posted 4 years ago #

    @samboll: really? Wamp worked like a charm for me. Can you maybe elaborate because I wanted to write a post about setting up and using a development server and was planning to use WAMP. But if there are problems with it, I might use XAMPP.

  5. lutor
    Member
    Posted 4 years ago #

    Hi...er I tried Xampp the first but I couldn't understand how to use it...

    I found in youtube a tutorial using wamp and I followed step by step...everything...And now, the message on screen is different. I think I can link it for you http://localhost/descubrirlasociedad/wp-admin/install.php but I think you won't be able to watch it because my intention was to install it off-line. The reason is I have no internet at home, and I wish to work in wordpress there. The error message, now, is

    Parse error: parse error in C:\wamp\www\descubrirlasociedad\wp-config.php on line 56

    ok?...And I also realized that the guy in youtube's tutorial was using a php text processor and i'm using microsoft word. I tried to install one but...this is a mess...Any idea?

  6. Samuel B
    moderator
    Posted 4 years ago #

    well you definitely can't use word - it adds extra junk
    you need to edit with notepad or another plain text editor like
    Metapad

  7. lutor
    Member
    Posted 4 years ago #

    Hi...I'm trying with note pad and the problem stills. Line 56 belongs to character */...I deleted that one, and error occurred then at line 66. In line 66 there was another */...so I deleted that one too...Ok? Then the same error on line 71,75 and...the same thing...I delete */ ok? Then...the last error is now on the last line (77) wich character is ?>...But deleting doesn't work anymore...so I realized that the main problem could be on Microsoft word and...I restored the file (ctrl+z all former deletes) and work on notepad...and one more time the same message

    What can I Do? We're honestly desperated

    Thanx Sam for your attention and kindness

  8. Samuel B
    moderator
    Posted 4 years ago #

    try this very basic code in your wp-config.php - make sure there aren't any blank lines or spaces at beginning or end of file when done.
    You can add the other stuff once you get the install working. change db values to yours of course

    <?php
    // ** MySQL settings ** //
    define('WP_MEMORY_LIMIT', '64M');
    define('DB_NAME', 'db-name');    // The name of the database
    define('DB_USER', 'db-user');     // Your MySQL username
    define('DB_PASSWORD', 'pass'); // ...and password
    define('DB_HOST', 'localhost');    // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    
    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix  = 'wp_';   // Only numbers, letters, and underscores please!
    
    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    
    /* That's all, stop editing! Happy blogging. */
    
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
  9. mrmist
    Forum Janitor
    Posted 4 years ago #

    The stuff that sites in between /* and */ are comments. It shouldn't make any difference if they are there or not, so you shouldn't need to delete them. What would make a difference is if you were to delete an opening comment mark /* and not remove the rest of the comment, as that would leave free text in your file.

  10. lutor
    Member
    Posted 4 years ago #

    YEEEEEEESSSSS!!!!! AT LAST.....THANK YOU!!!! WE LOVE YOU!!!!!

    WE PROMISE WE'LL LEARN MORE BEFORE NEXT TIME

    SERIOUSLY....

    WE LOVE YOU

    IT'S 21:35 IN SPAIN

    WE'RER TIRED AND CONFUSED...AND DIZZY

    WE LOVE YOU SAM

    THANK YOU

  11. Samuel B
    moderator
    Posted 4 years ago #

    just glad you have it working

  12. kannabiran
    Member
    Posted 4 years ago #

    Hi , follow the steps...

    1. First install wamp server in your system

    2.Download wordpress and unzip the file , Then put into the folder

    wamp/www/wordpress

    3. Then goto to the browser hit the url for ex.. http://localhost/phpmyadmin.

    4. then crate a new database name

    5. Then hit the url ..ex:http://localhost/wordpress

    6.Then proceed

  13. lutor
    Member
    Posted 4 years ago #

    Just one more question, our dearest Sam: Can we modify the script you sent us to change the language into spanish...I think I've got the file, thanks to the wordpress community in Spain, but I think we installed the generic version (in english).Anything else...Oh! just another question:

    Does this installation allow us to change the default aspect to customize our web with sheets and images from websuitex5 or photoshop?.

    Thank you very much to all, and specially you, sam
    How Can we ever repair you?

    Javi

  14. rizman
    Member
    Posted 4 years ago #

    To change your WordPress installation language, follow these steps (it's pretty easy)
    http://codex.wordpress.org/Installing_WordPress_in_Your_Language

    Does this installation allow us to change the default aspect to customize our web with sheets and images from websuitex5 or photoshop?.

    Do you mean modifiying the look of your site? If so, the answer is yes. Either just use a different theme, modifiy an existing theme (be careful under which license the theme is released) or create your own theme from scratch.

  15. Samuel B
    moderator
    Posted 4 years ago #

    open wp-config.php and find:
    define ('WPLANG', '');
    change it to
    define ('WPLANG', 'es_ES');
    now if you have a /languages folder with a .mo file in it (in your /wp-content folder), your blog will be Spanish

  16. lutor
    Member
    Posted 4 years ago #

    Thanks everybody for your attention. I'll try... Thanx Mr. Rizman. Thanx Mr. Samboll. Kisses and hugs from Spain.

    Javi

  17. lutor
    Member
    Posted 4 years ago #

    Hello there: I've got another problem with wordpress. When I try to run my dashboard (remember I installed wp locally) This message appears:

    "Your PHP installation appears to be missing the MySQL extension which is required by WordPress"

    I entered at "Your WP" forum but I found no reply. I don't know what to do. Mr. Samboll, u there? please, we need you....greetings from spain

  18. MichaelH
    Member
    Posted 4 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic