WordPress.org

Ready to get started?Download WordPress

Forums

Error establishing a database connection (3 posts)

  1. myshihtzu
    Member
    Posted 6 years ago #

    <<<Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.>>>
    -----------------------------------------------------------

    After about 3 days of trying and many efforts for up to host <<110mb.com>> but I still cannot get the wp-config.php file to open my database. I've change username and password and e-mail but I still cannot. tech support and they keep giving me suggestions and I keep doing them. However, still,

    when I run my wp-config.php I get:

    Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at z-1234.zipa.com. This could mean your host's database server is down.

    I edit wp-config.php

    // ** MySQL settings ** //
    define('DB_NAME', 'shihtzu'); // The name of the database
    define('DB_USER', 'shihtzu'); // Your MySQL username
    define('DB_PASSWORD', 'my password'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    I am trying to set up a mysql database for wp, but from the information I have read "localhost" will not work as the host name on a 110mb account. I'm using the Plesk control panel and it does not tell me the name of the host. Any Suggestions?

  2. MichaelH
    Member
    Posted 6 years ago #

    I believe localhost is correct for 110mb. If you can, use phpMyAdmin to access the database then once in phpMyAdmin you should see the name of the database at the top of the screen.

    Just a note, the last time I used 110mb, they offered Layered Panel, not Plesk, for the control panel.

    If you can't get the database info correct, also consider talking to your host.

  3. CognitiveCombine
    Member
    Posted 6 years ago #

    Perhaps you have tried this already, but it doesn't hurt to mention it.

    Lets assume my hosted account name is dingdong and I created a DB called shihtzu and a user called bob, so I would enter the db name as dingdong_shihtzu and the user as dingdong_bob and so forth. Did you do this already?

Topic Closed

This topic has been closed to new replies.

About this Topic