WordPress.org

Ready to get started?Download WordPress

Forums

Error establishing a database connection (3 posts)

  1. amm
    Member
    Posted 8 years ago #

    I am using Go Daddy as my host. My wp-config.php reads

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'sql_violethour'); // The name of the database
    define('DB_USER', 'sql_violethour'); // Your MySQL username
    define('DB_PASSWORD', 'mypassword'); // ...and password
    define('DB_HOST', 'mysql85.secureserver.net'); // 99% chance you won't need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    I have a mysql database called sql_violethour created and can create tables in it.
    I have disabled my personal firewall and privacy software. I have triple checked username, database name and have tried 'localhost' as well as the
    'mysql85.secureserver.net' value. Anyone have any insights?

  2. skippy
    Member
    Posted 8 years ago #

    Where was the sql_violethour database created? You mentioned "personal firewall" which makes me suspect that you created the database on your workstation?

    The database needs to be created on the database server supplied by your host. If GoDaddy told you to use mysql85.secureserver.net, then you'll need to double-check the login name and password, to make sure you've keyed them in correctly.

  3. amm
    Member
    Posted 8 years ago #

    Thanks - my database is on my host (Go Daddy) site - I mentioned the firewall as I read in a previous post that they can cause this error. I have checked the database name and username with Go Daddy. They confirmed that the username and database they create are always the same value (in this case, sql_violethour).

Topic Closed

This topic has been closed to new replies.

About this Topic