WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Error establishing a database connection (6 posts)

  1. percepts
    Member
    Posted 7 years ago #

    "Error establishing a database connection"

    yeah I know it sounds like I haven't set my databse or config.php properly but...

    I installed two copies elsewhere today without problems. I have installed on my local machine many times before without problems so this is something out of the ordinary (I think).

    I just downloaded latest version of WP 2.0.4

    Windows 2K
    Apache 2
    MySQL 4.1.1.13a
    PHP 4.3.2

    never had this problem before.
    I dropped all old database schemas and recreated. Checked passwords etc etc.

    any suggestions?

    p.s. just installed a local copy of, movabletype and had no database problems, plenty of others but not database.

  2. Austin Matzko
    Member
    Posted 7 years ago #

    This error message is produced at a very basic level, within the wpdb database class--a robust MySQL mini-library.

    If you haven't modified the wp-includes/wp-db.php file, it's almost guaranteed that there's something wrong either with your settings or with your database.

  3. percepts
    Member
    Posted 7 years ago #

    This is what MySQL says when wp tries to connect:

    1251 Client does not support authentication protocol requested by server; consider upgrading MySQL client

    why would that suddenly start happening. It worked fine before and now I'm trying to install an older version of wp so its defintely something with either apache or mysql on my machine but I don't know waht I have changed. I did reinstall MySQL but no change.

    Any clues?

    the correct params are being passed to the connect.

  4. Reaper-X
    Member
    Posted 7 years ago #

    MySQL 4.1 and above are using new password encryption and in order to use old authentification with MySQL 4.1 ++ you must put this parameter in your mysql configuration file (usually my.ini if you're not changing the default configuration path)

    old-passwords

    and after put that parameter into my.ini restart the mysql server (i assume you're installing fresh install on localhost) because most hosting service already use this parameter. After doing that step, reupdate your account or if you're using root account as the user update that too otherwise update only your mysql user account

    That's it finish =)

  5. percepts
    Member
    Posted 7 years ago #

    That worked great! You're a star.

    Thanks.

  6. mking10003
    Member
    Posted 7 years ago #

    I'm not quite as adept with SQL server, where do I make that change on a remote server, I'm having the same issue?

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic