WordPress.org

Ready to get started?Download WordPress

Forums

Error establishing a database connection (11 posts)

  1. gutielua
    Member
    Posted 8 years ago #

    I have problems with my blog:

    Are you sure you have the correct username and password?
    It's OK
    Are you sure that you have typed the correct hostname?
    It's OK
    Are you sure that the database server is running?
    It's OK

    Would could be? My webmaster host, told me that only my domanin that use WP have this problem.

    Also i upgrade to 2.0.4 and all still same.

    Any help? Tnx in advance...

    @ndrés

  2. Phil2006
    Member
    Posted 8 years ago #

    I have this same problem too . . . Cannot connect to database error! :(

  3. yosemite
    Member
    Posted 8 years ago #

    Try this thread: http://wordpress.org/support/topic/55826?replies=15

    Any of that click?

  4. gutielua
    Member
    Posted 8 years ago #

    Well, I read the topic from podz, but on my case all it's ok.

    I which case the server "localhost" could be responsable?

    This type or error as usual of wordpress only?

  5. jayoh
    Member
    Posted 8 years ago #

    most hosts use localhost to refer to the database server {as in, it's running on the same machine}, but sometimes you'll have to know it's own URI ... such as db.domain.com.

    double check with your host!

  6. gutielua
    Member
    Posted 8 years ago #

    I still troubles with my WP connection, on my Cpanel you can see this:

    Operating system Linux
    Kernel version 2.4.20-021stab028.17.777-smp
    Machine Type i686
    Apache version 1.3.33 (Unix)
    PERL version 5.8.6
    Path to PERL /usr/bin/perl
    Path to sendmail /usr/sbin/sendmail
    PHP version 4.3.11
    MySQL version 4.0.27-standard

  7. yosemite
    Member
    Posted 8 years ago #

    What did your host say?

  8. gutielua
    Member
    Posted 8 years ago #

    nothing, he didn't find the solution.

    i'm desesperate!

  9. yosemite
    Member
    Posted 8 years ago #

    Your host doesn't know where your MySQL server is? Read the post from jayoh, above.

    Paste your wp-config.php here (between backticks and without empty lines).

  10. gutielua
    Member
    Posted 8 years ago #

    // ** MySQL settings ** //
    define('DB_NAME', '*****');
    define('DB_USER', '*****');
    define('DB_PASSWORD', '*****');
    define('DB_HOST', 'localhost');

    // Change the prefix if you want to have multiple blogs in a single database.

    $table_prefix = 'wp_';

    define ('WPLANG', 'es_ES');

  11. yosemite
    Member
    Posted 8 years ago #

    You need to verify with your host that "localhost" is the correct MySQL host.

Topic Closed

This topic has been closed to new replies.

About this Topic