WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Error: Empty hostname for MaxCDN Test (23 posts)

  1. oraclealchemist
    Member
    Posted 11 months ago #

    I updated W3 Total Cache to the latest version (0.9.3) and didn't change any settings. However, when I click the button to test MaxCDN it now says: Error: Empty hostname

    The "Replace site's hostname" fields are filled in with the matching c-names from MaxCDN. Please let me know what I can check to see why I am receiving this error now.

    http://wordpress.org/plugins/w3-total-cache/

  2. GeldGorilla
    Member
    Posted 11 months ago #

    I got exactly the same problem.

    Images that I upload right now are not shown on the my website also.

    When I go to the url of the image I must fill in a captcha on the MaxCDN site which leads to... nothing!

    I can keep filling in the box but nothing happens.

  3. dougburger
    Member
    Posted 11 months ago #

    Same thing here. I tried Cloudfront, and W3 Total Cache kept giving me the ERROR: Empty Access Key. That was really strange, because it didn't have any trouble accessing my account and creating the distribution. Even tried opening a new AWS account, but still had the same issue.

    So, I signed up for MaxCDN, and I get ERROR: Empty hostname. Using the latest WP 3.6 and latest W3 Total Cache.

  4. rwkiii
    Member
    Posted 11 months ago #

    Me too. Mine had no problem with the test until updating to the new W3 Total Cache. Now I get a red box containing "Error: Empty hostname".

    Wish we didn't have this problem, but glad that it's likely not our configuration(s).

    We are also running WP 3.6 and the latest version of W3 Total Cache v0.9.3

  5. GeldGorilla
    Member
    Posted 11 months ago #

    Simple solution for now is to downgrade back to version 0.9.2.11: http://downloads.wordpress.org/plugin/w3-total-cache.0.9.2.11.zip

    Just unzip the package and overwrite all the files in your current wp-content/plugins/w3-total-cache directory. It will work all fine.

    What is the lesson?

    Never update immediately when it comes to W3TC. Just wait another 1 or 2 weeks and a newer version will probably already be available which fixed a lot of bugs of the version before that.

  6. mattjabs
    Member
    Posted 11 months ago #

    Here is a similar thread dealing with the same error but pertaining to the use of AWS Cloudfront rather than MaxCDN: http://wordpress.org/support/topic/v-093-cdn-cloudfront-error-empty-access-key/

  7. Millen
    Member
    Posted 11 months ago #

    I got the same problem.

    Is there a real solution to the problem yet or is there an update around the corner?

  8. ali.chakery
    Member
    Posted 11 months ago #

    I have the same problem .. the hostname is there and my CNAME is working but I get this error : Error: Empty hostname

    This plugin really has a poor support

  9. pixelwind
    Member
    Posted 11 months ago #

    Same problem here. Hopefully there's a bug fix soon.

  10. taptapio
    Member
    Posted 11 months ago #

    I'm trying to connect MAXcdn for the very first time... after a good hour of head scratching, i'm hoping that its the same problem that everyone on this thread is suffering...

    Any tips or tricks about getting me going much appreciated!

  11. HammyHavoc
    Member
    Posted 11 months ago #

    I get the same error, but it doesn't seem to affect it working properly.

  12. Anthony Somerset
    Member
    Posted 11 months ago #

    i got same error, for some sites, and some sites would work perfectly

    when i go to the plugin overview page on all the sites though, the maxcdn/netdna stats display correctly however so it seems its a possible fail in the tester rather than anything more serious (cant confirm at this stage though)

  13. Omega Supreme
    Member
    Posted 10 months ago #

    Anyone that still has CDN issues, I posted a working solution until this is resolved.

    http://wordpress.org/support/topic/error-empty-hostname-cname-list?replies=11

  14. KirkEisele
    Member
    Posted 10 months ago #

    The error is just on the test. The CDN is actually working in my case. You have to ignore the test button and instead save your changes and then view the source of your website. You should see some content pulling from MAXcdn. I did.

  15. Omega Supreme
    Member
    Posted 10 months ago #

    @Kirk,

    Good for you :)

    It seems to be a 50/50 issue, and I was hoping to be on the 50 side that works like yourself, but when I spoke to maxcdn, they could see it wasn't pulling on their end.

  16. Willie Jackson
    Member
    Posted 5 months ago #

    This is fixed in the next release.

  17. mattjabs
    Member
    Posted 5 months ago #

    Good deal. Thanks Willie.

  18. mnp2192
    Member
    Posted 5 months ago #

    this pluggin is saying I need an authorization key but I can't find it anywhere.

  19. Willie Jackson
    Member
    Posted 5 months ago #

    @mnp2192: sounds like you've enabled the CDN checkbox without configuring MaxCDN.

  20. dionsis
    Member
    Posted 4 months ago #

    Willie any idea when the next release is due?

  21. Willie Jackson
    Member
    Posted 4 months ago #

    @dionsis: Sorry, no ETA is available currently.

  22. dionsis
    Member
    Posted 4 months ago #

    In the interim is there a quick fix? My CDN is completely inactive because I cannot connect. I'd really like to get it back working. I'm a paying W3 Total Cache customer.

    I have logged 3 support tickets for various issues, I never hear back. I'm concerned I've wasted my money.

  23. Willie Jackson
    Member
    Posted 4 months ago #

    @dionsis:

    1. This issue doesn't prevent the CDN from working.
    2. Drop me a note so I can look up your tickets please.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.