WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Error during upgrade (8 posts)

  1. hibbers
    Member
    Posted 5 years ago #

    I tried to upgrade to 2.8 automatically - I got a message saying it was successful but now I get the following error when I try to access my control panel:

    Fatal error: Call to a member function read() on a non-object in /home/content/h/i/b/hibbers/html/wp-includes/theme.php on line 387

    And furthermore my website theme is all messed up (it seems to have partly reverted to the default theme - missing header and the default grey border have appeared)

    I did make a backup by ftp-ing everything on my host to a local folder - if I just copy everything back to the server will it go back to 2.7.1 or will that just mess things up even more?

    please help!

    thanks!

  2. hibbers
    Member
    Posted 5 years ago #

    Well, I've managed to get the control panel back by replacing themes.php and my theme folder with the pre-upgrade backup copies. This seems to have solved the problem, but do I need to do anything else, for example do I need to somehow upgrade themes.php again?

  3. AnjaLeBlanc
    Member
    Posted 5 years ago #

    I've run into the same problem (manual upgrade). The theme looked all right, but the admin interface got the error message (theme.php line 387). I just went back to the previous theme.php and it seems to work.
    I wonder whether this has something to do with links since I have the all my themes in a linked directory.
    I hope this is something that 2.8.1 will fix.

  4. coolgates
    Member
    Posted 5 years ago #

    This solution worked for me.

  5. hibbers
    Member
    Posted 5 years ago #

    thanks coolgates that looks like it would have sorted my problem.. Think I'll stick with my old theme.php for now because I'm paranoid about messing it up!

  6. mstegink
    Member
    Posted 5 years ago #

    It is a problems with the access control settings of (one of) the theme's subfolder. To solve this make sure they are all readable.

    See http://www.bos89.nl/1772

  7. brandon_rhodes
    Member
    Posted 4 years ago #

    Good call, @mstegink! I had a hidden ".svn" directory, because I use Subversion version control on my custom theme, that was not set world-readable, so my www-data user couldn't see it! I've changed the directory's permissions and WordPress is now quite happy. Thanks! :-)

  8. jeremywpalmer
    Member
    Posted 4 years ago #

    Thanks mstegink - A quick Google search led me to this post before I wasted hours trying to solve the problem. I'm sure I never would have found the answer on my own!

Topic Closed

This topic has been closed to new replies.

About this Topic