WordPress.org

Ready to get started?Download WordPress

Forums

WP Online Store
error Duplicate entry '263' for key 'PRIMARY' (4 posts)

  1. allanit
    Member
    Posted 1 year ago #

    I originally posted this in the plugins section Sorry for re-posting it but I have some additional information now and it belongs here.

    Hi

    I am having a problem that started today. Below is the error message that appeared in my logs every time I do anything weather it is related to WP_online_store or not.

    [Mon May 13 16:12:27 2013] [warn] [client 192.168.0.1] mod_fcgid: stderr: WordPress database error Duplicate entry '263' for key 'PRIMARY' for query INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES (263, 'Display Product Sort Order', 'PRODUCT_SORT_ORDER', '0', 'Do you want to display the Product Sort Order column?', 8, 29, '', '', NULL, NULL); made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), include_once('/plugins/wp-online-store/WP_online_store.php'), generate_config, referer: http://mysite/wp-admin/admin.php?page=WP_online_store&submenu=index

    Below is the configuration table record 263

    "263","Display Product Sort Order","PRODUCT_SORT_ORDER","0","Do you want to display the Product Sort Order column?","8","29","0000-00-00 00:00:00","0000-00-00 00:00:00","",""

    Any ideas?

    On line 234 of WP_online_store.php is the following code

    $wpdb->query("INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES (263, 'Display Product Sort Order', 'PRODUCT_SORT_ORDER', '0', 'Do you want to display the Product Sort Order column?', 8, 29, '', '', NULL, NULL);");

    which is responsible for creating record 263 in the configuration table. My problem appears to be that every time the screen changes this code is run (weather in the dashboard or on the front end). Does any one have any suggestions how to fix this problem?

    http://wordpress.org/extend/plugins/wp-online-store/

  2. allanit
    Member
    Posted 1 year ago #

    Incas there is I conflict with a plugin that I am unaware of here is a list of the installed plugins on my instalation.

    Akismet 2.5.7
    All In One SEO Pack 2.0.1
    Better WP Security 3.4.10
    BM Custom Login 1.6.6
    BWP Google XML Sitemaps 1.2.1
    Comprehensive Google Map Plugin 7.0.31
    Exclude Pages from Navigation 1.92
    Flexi Pages Widget 1.6.11.1
    Form Manager 1.6.40
    Hierarchical Link Categories 2.0.1
    Image Widget 4.0.7
    Link Library 5.7.9.4
    MailPress 5.3
    Orderli 1.2
    Revision Control 2.1
    Twenty Eleven Theme Extensions 1.2
    Ultimate TinyMCE 4.6
    WordPress Font Uploader Free 1.3.2
    WP Maintenance Mode 1.8.7
    WP Online Store 1.3.1

  3. baldguy67
    Member
    Posted 1 year ago #

    I have seen this before and I have no idea why it runs this particular line all the time. Once the plugin is installed and running you can hide this line in WP_online_store.php by putting // at the beginning of it so it appears like this:

    //$wpdb->query("INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES (263, 'Display Product Sort Order', 'PRODUCT_SORT_ORDER', '0', 'Do you want to display the Product Sort Order column?', 8, 29, '', '', NULL, NULL);");

  4. allanit
    Member
    Posted 1 year ago #

    I thought I would follow up a bit with this. Some info that may help is, this error happens if you have some testing products in the cart and then you delete them one at a time (because you want to keep the rest of the configuration) leaving you with no products. Then you start to enter new products the error above starts to cause problems. I have had 2 people I am helping set up their cart with this problem so have been able to track it down this far. Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic