WordPress.org

Ready to get started?Download WordPress

Forums

WP Smush.it
[resolved] [error] => Could not get the image (5 posts)

  1. MasterJuan
    Member
    Posted 4 months ago #

    Hello everyone!

    I have a new website and I uploaded my first photos with format .png .jpg and .svgz.

    None of them going throught the process of Smush.it compress!

    And when I enabled the debug option I am seeing tha error

    stdClass Object
    (
    [src] => http://square.gr/wp-content/uploads/2014/02/STREET..jpg
    [error] => Could not get the image
    [id] =>
    )

    https://wordpress.org/plugins/wp-smushit/

  2. David
    WPMU DEV Support Staff
    Posted 4 months ago #

    Hi @MasterJuan,

    Hope you're well today! :)

    Could you let me know if those images are all under 1MB? I'm assuming so if you didn't receive an error on that, but just checking.

    Also, are you able to see the images after uploading them? Does the upload process itself complete?

    If possible, could you provide a link to one of the images?

    Hopefully that'll help us get it sorted. :)

    Thanks,
    David

  3. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 3 months ago #

    Hey there.

    We haven't heard from you in awhile, so I just wanted to check in to make sure all was good.

    This thread was marked resolved, but please, if you still need help then just respond and open it back up. We can then take it from there. :)

    Hope you have a fantastic day!

  4. MasterJuan
    Member
    Posted 3 months ago #

    Hello again.

    I apologize for my delay.

    I am notice these:
    1) Yeah, you are right about the limitation of 1MB image size.
    2) My .svgz and .gif images are not compressed.
    3) If I smush each image itself then everything goes well except from some images which I am seeing the result "no savings" even if these are jpg images.
    4) When I select all the images and running "bulk smush" then I am taking a weird results... Then I realize that it happens cause I had enabled the option "Enable debug processing". If uncheck this option and try to re-smush my media section reload fine but the most of the times nothing happended and I must do it for each image separately.

    In general, which must be the optimize size for a web image, if you want to show it in full screen preview?

    Thank you for your interest.

  5. David
    WPMU DEV Support Staff
    Posted 3 months ago #

    Hi @MasterJuan,

    Thanks for your reply. The optimal image file size will totally depend on the image, actually. On the other hand, if you're asking about the image dimensions, that really depends as well. It's probably best to media queries to handle viewing through different devices.

    As for the issues you're seeing with the debug option turned on, could you please provide a screenshot so we could see what you're seeing there?

    Thanks,
    David

Reply

You must log in to post.

About this Plugin

About this Topic

Tags