WordPress.org

Ready to get started?Download WordPress

Forums

Error Connecting to Database Then... (2 posts)

  1. WDWRK
    Member
    Posted 6 months ago #

    Hello!

    I may have created a mess! I have followed suggestions for repairing the Error Connecting to Database. Which I was intermittently receiving during accessing my site.

    Now I am getting ERR_EMPTY_RESPONSE, From Chrome

    This happened after I have Repaired the tables in PHPAdmin, from suggestions online, to ridding of the Error Connection dialog. I have also attempted other fixes, plugins folder, checking config file, checking htaccess file.

    Help! Any suggestions very welcome. :)

  2. Tara
    Member
    Posted 6 months ago #

    I have also attempted other fixes, plugins folder, checking config file, checking htaccess file.

    Error connecting to your database: You are getting this error because WP is unable to establish a database connection. Reason why WP is unable to establish a database connection can vary. It could be that your database login credentials are wrong or have been changed. It could be that your database server is unresponsive. It could be that your database has been corrupted. Also, There could be other factors as well.
    To troubleshooting this problem:
    - double check your wp-config.php file settings for the database name, database username and database password. This is where most errors occur.
    - Then check that you don't need to change the database host from "localhost" to something else. You can get that info from your hosting provider.
    - Check you have actually created a database with the same database name as is in your wp-config.php file.
    - Last, but not least, if all that information is correct your database probably has a problem with it, and you may need to contact your hosting provider if the database server is online / if they have any other problem at their end, or they made any changes to your account, or if there are any limitations/restrictions, if the hosting package is set to Windows and not Linux, etc.

Reply

You must log in to post.

About this Topic