WordPress.org

Ready to get started?Download WordPress

Forums

Customizr
Error code when installing backupbuddy (6 posts)

  1. Cathryn999
    Member
    Posted 5 months ago #

    G'day Nico,
    Sorry to bug you, just wondering if you've had any reports of conflicts when installing backupbuddy? I'm getting the error code below on install. I can activate the plugin but all sorts of crazy things happen and eventually the site crashes. ANy ideas? Thanks in advance, Cathryn.

    Warning: Invalid argument supplied for foreach() in /home/XXXXXX/saildarwin.com.au/wp-content/themes/customizr/inc/class-fire-init.php on line 643

  2. W.P. Ginfo
    Member
    Posted 5 months ago #

    It is fairly common for updates and/or plugins to trip up your site.
    Have you tried the following:

    1. Use FTP to access your site
      e.g. http://filezilla-project.org/download.php
    2. rename all plugins by putting a '0' in front of each plugin -folder;
      ../wp-content/plugins
    3. Check if the access / 'normal functioning' has been restored
    4. If so: one-by-one, remove the '0', checking every time to see if the problem re-occurs.
    5. when the problem re-occurs, you've found the source of the problem; Delete and find a similar plugin that works with your site
    6. alternatively: FTP:Delete; Then download and install / activate a NEW version of the problematic plugin and see if this works.

    Alternatively:
    Instead of ftp, use the webaccess dashboard functions provided by the webhost.
    This usually is not as versatile and more cumbersome.

  3. Cathryn999
    Member
    Posted 5 months ago #

    Thanks Gino, yes, I've renamed plugins and one by one reactivated. So far so good, but I'm just a bit concerned about the error code when installing backupbuddy. Just wondering if anyone else has experienced this conflict/error - backupbuddy is a pretty common and robust plugin. Maybe my theme is corrupt? :-( When I switch to 20-13 my problems go away and backupbuddy installs fine. But I LOVE LOVE LOVE customizr! :-)

  4. ElectricFeet
    Member
    Posted 5 months ago #

    The error you're getting is:
    Warning: Invalid argument supplied for foreach() in /home/XXXXXX/saildarwin.com.au/wp-content/themes/customizr/inc/class-fire-init.php on line 643
    My (standard) class-fire-init.php file is shorter than 643 lines. My guess is that it's been edited somewhere along the way and one of your plugins is causing some of the inserted (and previously-unused) code to be run, causing the error.

    Reinstall Customizr to see if that fixes the issue. If it doesn't, I've been using BackUpWordPress for some time with no problems.

  5. nikeo
    Member
    Theme Author

    Posted 5 months ago #

    Hi Cathryn999, where are you standing with this issue?

  6. Cathryn999
    Member
    Posted 5 months ago #

    Hi Nik, Backup buddy seems to be working fine, and I noticed when I installed another completely unrelated plugin I got the same error message so my guess is the ElectricFeet is right, somewhere along the way some other plugin has modified class-fire-init.php. I plan to upgrade to the newest version of Customizr shortly, I suspect that will resolve the error message.
    cheers, love your work!

Reply

You must log in to post.

About this Theme

About this Topic