WordPress.org

Ready to get started?Download WordPress

Forums

Email Before Download
Error: Class downloadable_file not found line 147 (10 posts)

  1. robotsushi
    Member
    Posted 1 year ago #

    The full error:
    Fatal error: Class 'downloadable_file' not found in /path/to/wp-content/plugins/email-before-download/email-before-download.php on line 147

    I am using all the most recent versions of WordPress, Email Before Download, Contact Form 7, and Download Monitor. I have configured the shortcode correctly using all the correct IDs. This seems like a compatibility issue. What's going on?

    http://wordpress.org/extend/plugins/email-before-download/

  2. mandsconsulting
    Member
    Plugin Author

    Posted 1 year ago #

    Hi robotsushi,

    Thanks for letting us know about your issues.

    The author of the Download Monitor finally released his new version.
    Recently we discussed that at http://wordpress.org/support/topic/new-version-of-downlaod-monitor?replies=2 so currently we are working on supporting it. The new version and the older one are not compatible and we don't know yet how far this incompatibility goes. We will let you know about our new updates.

    So far you can use our plugin with the old version of Download Manager which is still available at http://downloads.wordpress.org/plugin/download-monitor.3.3.6.zip
    Sorry for the inconveniences. We are working hard on fixing our plugin so it is up to date and compatible.

  3. Ircsome
    Member
    Posted 1 year ago #

    fyi, getting same problem with

    wordpress 3.6-beta4-24523
    email before download Version 3.2.3
    download monitor 1.0.1

    Class downloadable_file not found line 147

  4. mandsconsulting
    Member
    Plugin Author

    Posted 1 year ago #

    Hi ircsome,

    As mentioned above, we are having some compatibility issues with the current version of Download Monitor (1.0.1). Please follow the link above to download the older, but compatible version of DM.

  5. Ircsome
    Member
    Posted 1 year ago #

    Have done, and can confirm the older version of DM works fine. Thanks.

  6. speculando
    Member
    Posted 1 year ago #

    Hi,
    I just re-installed the previous version (DM 3.3.6) but still not working :(

    "Fatal error: Class 'downloadable_file' not found in /path/to/wp-content/plugins/email-before-download/email-before-download.php on line 147"

    please, How can I fix this ?

  7. mandsconsulting
    Member
    Plugin Author

    Posted 1 year ago #

    Hi speculando,

    This error says only that the older installation of the DM is not found in your instance of wordpress.
    So, either you still have the new version active, or the old version is not installed or not activated

  8. bagusfikri
    Member
    Posted 1 year ago #

    Hi I still have an error

    Notice: Undefined index: ebd_downloads in /home/bagusfi1/public_html/blog/wp-content/plugins/email-before-download/email-before-download.php on line 304
    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1]
    SELECT * FROM wp_ebd_item WHERE id = ;

    Notice: Trying to get property of non-object in /home/bagusfi1/public_html/blog/wp-content/plugins/email-before-download/email-before-download.php on line 327
    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1]
    SELECT * FROM wp_download_monitor_files WHERE id = ;

    Notice: Trying to get property of non-object in /home/bagusfi1/public_html/blog/wp-content/plugins/email-before-download/email-before-download.php on line 337

    Notice: Trying to get property of non-object in /home/bagusfi1/public_html/blog/wp-content/plugins/email-before-download/email-before-download.php on line 341
    {"mailSent":false,"into":"#wpcf7-f139-p124-o1","captcha":null,"message":"Please select at least one of the documents","onSentOk":["\"document.getElementById('wpm_download_').style.display = 'inline'; document.getElementById('wpm_download_').innerHTML='You should select the files to dowload.'; \""]}

  9. mandsconsulting
    Member
    Plugin Author

    Posted 1 year ago #

    Hi bagusfikri,

    The errors that you sent imply that there might be something wrong with the way you used a short code.
    Could you please check this sticky forum?
    http://wordpress.org/support/topic/plugin-email-before-download-sticky-getting-faster-support?replies=17

  10. richp58
    Member
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic