WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[resolved] Error after wordpress 3.8 update (5 posts)

  1. B.V.Ramanarao
    Member
    Posted 7 months ago #

    I have been using this plugin for my site. When I started using this plugin I used to get compatibility issues. Now I am very much happy that I learn so much on how to set up this to protect from malicious attacks.

    The following is the warning I am getting right now after updating my WP core to 3.8. at plugin dashboard, under subscribe widget.

    "Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'bit51_bwps::change_foolic_input_size' was given in /home/[username]/public_html/[sitename]/wp-includes/plugin.php on line 199"

    I want to know what went wrong with "this plugin/at my end" after word press 3.8 update?

    My Second Error:
    The plugin's hide backend feature for "wp-login.php along with secret code" revealing if we try to hack with "/wp-login.php?loggedout=true".
    I just changed the mode rewrite rules generated by this plugin in .htaccess as follows, to protect from the above said hack.

    RewriteCond %{QUERY_STRING} ^loggedout=true
    RewriteRule ^.*$ /wp-login.php? [R,L]
    So that if someone wish to go with "loggedout=true" will get my customized 404 error, but they don't get wp-login.php?(MySecretCode)

    I hope, the plugin authors will find the better way to solve the above errors. But I can understand and really appreciate the authors patience and hard work to develop this plugin.

    Last but not least, though it is having some minor errors, I prefer to rate this plugin 5*****. It also works well with other wordpress security plugins Wordfence, SecuriScanner, and Acunetix WP Security.

    http://wordpress.org/plugins/better-wp-security/

  2. B.V.Ramanarao
    Member
    Posted 7 months ago #

    Small correction to above query. I verified one by one, and I found that the above said problem is not coming with WordPress 3.8 update. The plugin itself displaying error after updating its recent version. Better WP Security v3.6.1 is having this error. Previous version is working well.
    So, no problem with wordpress latest updated version 3.8, but BWS is displaying error in plugin dashboard.

  3. B.V.Ramanarao
    Member
    Posted 7 months ago #

    Excellent work by "Better WP Security" plugin developers. Just couple of minutes back v3.6.2 was released to sort out the issue mentioned above. Within the 16hours of the error report, these guys resolved the concern.

    Tons of thanks to all the Geeks and I really grateful to all of them.
    Opps! WordPress.org does not allow me to rate more than 5*****. Sorry guys, I can only give 5***** for now.
    Keep rocking brothers... :D

  4. Mike-Ism
    Member
    Posted 7 months ago #

    You're on wp 3.8? try logging in with a user level below administrator and let me know if you get a 500 error. I have been seeing this error on all sites running 3.8 since beta testing. Administrators can access the dashboard just fine, lower users get the server error.

  5. B.V.Ramanarao
    Member
    Posted 7 months ago #

    Working fine with all user levels too. Change server tweaks like password difficulty level to Subscriber etc. That might work for you. I tested both live and local server sites with all user levels. I did not find any errors till now as you mentioned. My settings at Password difficulty level under server tweaks at Subscriber not just for Administrator. I hope this might resolve your issue. Have a nice day.

Reply

You must log in to post.

About this Plugin

About this Topic