WordPress.org

Ready to get started?Download WordPress

Forums

Genesis Simple Sidebars
[resolved] Error after updating to PHP 5.4 (19 posts)

  1. tditmore
    Member
    Posted 1 year ago #

    My website host 1and1 required me to update to PHP 5.4. Before I did that, I updated WordPress to 3.5.1 and updated all plugins. Now I am getting these error codes atop all my admin pages:

    Warning: Illegal string offset 'name' in /homepages/7/d352737780/htdocs/wp-content/plugins/genesis-simple-sidebars/plugin.php on line 106

    Warning: Illegal string offset 'description' in /homepages/7/d352737780/htdocs/wp-content/plugins/genesis-simple-sidebars/plugin.php on line 108

    Sometimes--but not always--I get these codes instead of being able to pull up my website at all: http://www.editmore.com.

    I know very little about computer programming; the person who designed my site left the job where I had access to her, and I really don't know what I should do to fix this. I saw a similar complaint on the larger WordPress forum, and the poster was advised to report this problem to the developers of Simple Sidebar, so that's what I'm doing here. Please let me know how I can fix this problem.

    http://wordpress.org/extend/plugins/genesis-simple-sidebars/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    Check your wp-config.php & see if WP_DBUG is set to true. If so put // at the beginning of the line.

    I'll make a note to have a look at the plugin.

  3. tditmore
    Member
    Posted 1 year ago #

    Sorry to be dense, but like I said, I know very little about this. Can you tell me where to begin to look for the wp-config.php?

  4. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    If you install WP manually you create wp-config.php. If your host installed WP for you then contact your host to ask for the location of wp-config.php.

  5. FreestyleMD
    Member
    Posted 1 year ago #

    Hi Ron , Just thought I'd chip in as I have just set up a local test version of my website using EasyPHP and get the exact same error messages as tditmore (apart from the pathnames, obviously)

    Debug was set to false in my wp-config

    Live site server is running PHP 5.3.18 Local Servver is PHP 5.4.12

    If you want me to provide you with any other clues I'd be happy to help ...

  6. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    @FreestyleMD - If it's not in your wp-config.php then error reporting is enabled in your php.ini. You'll have to look up where php.ini is located in your OS.

  7. FreestyleMD
    Member
    Posted 1 year ago #

    I appreciate what you are saying, but switching off error reporting isn't necessarily an ideal solution, although it will help while I am just making cosmetic changes to the website.

  8. FreestyleMD
    Member
    Posted 1 year ago #

    I just realised that I have another website using simple sidebars on the same test server and that one works fine.
    What is different between the two is that the site which throws up the error message has a sidebar with an id of 0 which cannot be edited or deleted.

    I looked in the ss_settings field in the database and found that the first part of the field had

    a:5:{i:0;s:20:"__return_empty_array"; .... etc

    at the beginning, so I changed this to match a working sidebar setting and the errors have disappeared

  9. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    @FreestyleMD - thanks for reporting that back. The bug that created the bogus sidebar was fixed but some people still have it stuck in their settings.

  10. bergman
    Member
    Posted 1 year ago #

    I a one who has IDs of 0 in a few installations of the plugin. It works fine using php 5.3 but breaks in php 5.4.

  11. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    The only way to fix it with the current plugin is delete the simple sidebar settings in the DB. Are you comfortable with doing that?

  12. FreestyleMD
    Member
    Posted 1 year ago #

    You don't have to delete everything though just

    i:0;s:20:"__return_empty_array";

    and subtract 1 from the first integer after a:

  13. WebEndev
    Member
    Posted 9 months ago #

    I am seeing the same problem.
    Any timing on a release of the plugin to fix it?
    Thanks

  14. WebEndev
    Member
    Posted 9 months ago #

    I deleted __return_empty_array from ss_settings in the options table, and it got rid of the bogus "0" ID sidebar.
    Fixed... disregard the above I posted.

  15. Kensterz
    Member
    Posted 8 months ago #

    I have the same problem with the error message. Where do I go to get to ss_settings? I tried following the error message and that led me to the plugin.php however there is nothing that looks like i:0;s:20:"__return_empty_array";

  16. Kensterz
    Member
    Posted 8 months ago #

    Nevermind I found the problem thanks

  17. fisher.msu
    Member
    Posted 5 months ago #

    Hey guys I'm experiencing the same issue. I have looked through the WP_Options in phpmyadmin in the DB and can't find ss_settings or I:0,s:20:"_return_empty_array".
    I am running php 5.4.21.

    Any help would be appreciated. Thanks

  18. minivip
    Member
    Posted 5 months ago #

    look for ss-settings and not ss_settings

  19. mbeasi
    Member
    Posted 4 months ago #

    I just wanted to thank FreestyleMD for this:

    You don't have to delete everything though just

    i:0;s:20:"__return_empty_array";

    and subtract 1 from the first integer after a:

    We just ran into this problem after updating mysql, and that solution worked perfectly for me. And not deleting all the settings allowed me to keep the working sidebars, which was great.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic