WordPress.org

Ready to get started?Download WordPress

Forums

error after moving to new server (7 posts)

  1. supermartha
    Member
    Posted 7 years ago #

    My site was just moved to a new server (with the same URL). I updated the wp-config.php file with my new mySQL data, and got this error on my index page:

    "Fatal error: Call to undefined function language_attributes() in /home/.maska/solilo_martha/migratorymushroom.soliloquise.com/wp-content/themes/default/header.php on line 2"

    Also, if I try to log in to the admin panel using the "admin" username, it gives me an "invalid username" error.

    Any ideas on how to fix this?

  2. MichaelH
    Member
    Posted 7 years ago #

    The undefined error may be a result of the fact you don't have a complete and intact set of WordPress files. Visit http://wordpress.org/download/release-archive/ and get a new download of the version you are using (it is 2.0 correct?) and use that to upload to your new host.

    You might need to use phpMyAdmin to determine what user is in your wp_users table. You might need to follow one of the Resetting_your_password procedures also.

  3. supermartha
    Member
    Posted 7 years ago #

    I re-uploaded WordPress, and got a defualt WordPress template with a 404 error.

    My username in the wp_users table is definitely admin. There was a table called "wp_blogusers" that appeared to be blank, so I added my username and password. Now it lets me log in, but instead of taking me to the dashboard, it gives me "You do not have sufficient permissions to access this page."

  4. MichaelH
    Member
    Posted 7 years ago #

    What was the $table_prefix in the old wp-config.php file. It should be the same on the new server.

  5. supermartha
    Member
    Posted 7 years ago #

    Yeah, it's the same.

    Would it be possible to just back up all my blog posts and pages from mySQL, re-install WordPress, and restore the old posts and pages?

  6. MichaelH
    Member
    Posted 7 years ago #

    The answer, supermartha, is yes.

    Review Moving WordPress, Backing_Up_Your_Database, and Restoring_Your_Database_From_Backup.

  7. sd12013
    Member
    Posted 6 years ago #

    Hi Michael (or anyone that may have an idea), I hate to piggy back on someone else's issue but mine is very similar. I backed up my files, moved to a new host and restored - mostly successfully. All my posts are there but I get some errors at the bottom of the page:

    Warning: Missing argument 1 for query_posts() in /homepages/33/d197604765/htdocs/public_html/annieblog/wp-includes/query.php on line 19

    I opened the query.php file and nothing seemed obvious like a wrong path so I'm stumped. The site works for the most part. It's just annoying to see the errors at the bottom of the page. Any ideas? Thanks for you help.

Topic Closed

This topic has been closed to new replies.

About this Topic