WordPress.org

Ready to get started?Download WordPress

Forums

Vantage
[resolved] Error after install (10 posts)

  1. Doe3
    Member
    Posted 10 months ago #

    Hi,
    I've just done a clean install of WordPress and wanted to use this theme, which looks awesome by the way, but I get this message in wp admin:

    Fatal error: Call to undefined function wp_get_theme() in /data/c/o/coachingtohappyness.com/web/wp-content/themes/vantage/extras/settings/settings.php on line 65

    When I go to the website everything looks normal, but I can't access the dashboard at all. Whereever I try to go the same error message appears and nothing else, except if I type the domain name of the site and there it looks normal, but of course without the admin area no can do. For now I just disabled the theme via ftp.

    Any ideas? Thanks

  2. Greg Priday
    Member
    Theme Author

    Posted 10 months ago #

    H i Doe3. wp_get_theme is a function that was added in WordPress 3.4. If you update to the latest version (3.6.1), everything should work for you.

    Hope that helps :)

  3. Doe3
    Member
    Posted 10 months ago #

    I do have 3.6.1
    I just installed WordPress on a new website and it's naturally running the latest version.

  4. Greg Priday
    Member
    Theme Author

    Posted 10 months ago #

    That's very odd. I searched for some other threads on the undefined wp_get_theme issue and they all seemed to be resolved by updating to the latest version of WordPress.

    Does anyone else have any ideas?

    Doe3, if you log in via FTP, then open up wp-includes/theme.php, can you see the wp_get_theme on around line 92? Just search for 'function wp_get_theme'? If it's there, then I'm stumped...

  5. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    I happened to have installed this theme last night (to answer a different thread - turned out to be a different Vantage theme) on a test site and it worked fine.

    @Doe3 - looks like you've gotten major errors in three different themes, so I'd guess that something may be wrong with your WP install. Have you tried reinstalling it?

  6. Doe3
    Member
    Posted 10 months ago #

    Thanks to both of you.
    I checked theme.php and that line is only found in line 1936, but wihtout the quotes like this

    // If no args passed then no extra checks need be performed
    if ( func_num_args() <title>function wp_get_theme</title><= 1 )
    return true;

    This time I used my hosting provider's automated wordpress install in Hungarian, but maybe something went wrong. Everything looks fine with the defaul TwentyTwelve theme though...

    I guess I'll have to try reinstalling it...

  7. Greg Priday
    Member
    Theme Author

    Posted 10 months ago #

    If there isn't a full definition of wp_get_theme in the theme.php file, then my only guess is that the auto installer is installing an old or modified version of WordPress. If you log into your WP admin, and check the 'Right Now' it should tell you what version of WordPress you're running, or possibly hint that it's a modified version.

  8. Doe3
    Member
    Posted 10 months ago #

    You're right, it installed 3.3.2 instead of 3.6.1

    What do you recommend? Clean install from scratch or update?

  9. Greg Priday
    Member
    Theme Author

    Posted 10 months ago #

    Updating should do the trick :)

  10. Doe3
    Member
    Posted 10 months ago #

    Thank you!!! It worked and now everything is fine.
    Really appreciate the help.

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.