WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
Error (8 posts)

  1. ragmaster
    Member
    Posted 3 years ago #

    Hi,

    The plugn seems to be loading, but the document doesn't appear.

    Here is the URL to the page:

    http://www.brixhamdanceworks.com/schedule/

    Here is the error message:

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; .NET CLR 1.1.4322)
    Timestamp: Wed, 29 Jun 2011 17:57:41 UTC

    Message: 'this.B[...]' is null or not an object
    Line: 348
    Char: 113
    Code: 0
    URI: http://www.brixhamdanceworks.com/wp-content/plugins/google-document-embedder/proxy.php?jsfile=gview/resources_gview/client/js/3366545377-gview_local_gview_base_mod.js

    Thanks in advance

  2. k3davis
    Member
    Plugin Author

    Posted 3 years ago #

    ragmaster,

    The page isn't currently calling the plugin, but one suggestion is to try switching to the Google Standard Viewer which does not do the proxy call that's resulting in an error for you.

  3. ragmaster
    Member
    Posted 3 years ago #

    Sorry i removed it for the client, i've put it back.

    http://www.brixhamdanceworks.com/schedule/

    The 'standard viewer' doesnt work at all, the enhanced viewer seems to almost work but the PDF doesnt show up

    Thanks!

  4. k3davis
    Member
    Plugin Author

    Posted 3 years ago #

    No need to be sorry - if it doesn't work, I don't expect you to leave it there. :)

    That said - I've looked at that page in IE9, Firefox 5, and Chrome 12, and the PDF is displaying in the viewer exactly as I'd expect; no errors. Are you sure it's not a local issue? Have you tried clearing your cache, etc.?

  5. mikeambrosio
    Member
    Posted 3 years ago #

    Not sure if this means anything, but...

    In FF 4 it works near flawlessly in either viewer.

    In IE8, here's what I see...

    Standard viewer - it won't finish loading, looking for https://www.google.com/accounts/Service>ogin?...

    Enhanced viewer I get errors and the viewer will open but no PDF shows. Here is the error I get:

    Webpage error details
    
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C; Tablet PC 2.0; AskTbFWV5/5.12.2.16749)
    Timestamp: Tue, 19 Jul 2011 21:58:16 UTC
    
    Message: 'this.B[...]' is null or not an object
    Line: 348
    Char: 113
    Code: 0
    URI: http://www.accelerateyourfatloss.com/wp-content/plugins/google-document-embedder/proxy.php?jsfile=gview/resources_gview/client/js/3366545377-gview_local_gview_base_mod.js
    
    Message: 'this.B[...]' is null or not an object
    Line: 348
    Char: 113
    Code: 0
    URI: http://www.accelerateyourfatloss.com/wp-content/plugins/google-document-embedder/proxy.php?jsfile=gview/resources_gview/client/js/3366545377-gview_local_gview_base_mod.js
    
    Message: 'this.B[...]' is null or not an object
    Line: 348
    Char: 113
    Code: 0
    URI: http://www.accelerateyourfatloss.com/wp-content/plugins/google-document-embedder/proxy.php?jsfile=gview/resources_gview/client/js/3366545377-gview_local_gview_base_mod.js
    
    Message: 'this.B[...]' is null or not an object
    Line: 348
    Char: 113
    Code: 0
    URI: http://www.accelerateyourfatloss.com/wp-content/plugins/google-document-embedder/proxy.php?jsfile=gview/resources_gview/client/js/3366545377-gview_local_gview_base_mod.js
    
    Message: 'B[...]' is null or not an object
    Line: 377
    Char: 334
    Code: 0
    URI: http://www.accelerateyourfatloss.com/wp-content/plugins/google-document-embedder/proxy.php?jsfile=gview/resources_gview/client/js/3366545377-gview_local_gview_base_mod.js
    
    Message: 'B[...]' is null or not an object
    Line: 377
    Char: 334
    Code: 0
    URI: http://www.accelerateyourfatloss.com/wp-content/plugins/google-document-embedder/proxy.php?jsfile=gview/resources_gview/client/js/3366545377-gview_local_gview_base_mod.js
    
    Message: 'B[...]' is null or not an object
    Line: 377
    Char: 334
    Code: 0
    URI: http://www.accelerateyourfatloss.com/wp-content/plugins/google-document-embedder/proxy.php?jsfile=gview/resources_gview/client/js/3366545377-gview_local_gview_base_mod.js
    
    Message: 'B[...]' is null or not an object
    Line: 377
    Char: 334
    Code: 0
    URI: http://www.accelerateyourfatloss.com/wp-content/plugins/google-document-embedder/proxy.php?jsfile=gview/resources_gview/client/js/3366545377-gview_local_gview_base_mod.js
    
    Message: 'this.B[...]' is null or not an object
    Line: 348
    Char: 113
    Code: 0
    URI: http://www.accelerateyourfatloss.com/wp-content/plugins/google-document-embedder/proxy.php?jsfile=gview/resources_gview/client/js/3366545377-gview_local_gview_base_mod.js

    Now, here's the interesting part...

    When in IE8 using the Standard Viewer, if I log OUT of my GMail account the viewer works just fine. (I am wondering if this is why you can not seem to duplicate other users issues).

    Hope this helps a little. Sure could use a solution.

    Thanks,
    Mike

  6. k3davis
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Mike,

    I am aware of an issue with using the viewer in certain situations if you are not logged into any google account. This is a limitation of the viewer, and somewhat unpredictable, and is not related to the plugin directly. I wish it were - then I would try to fix it. ;) Unfortunately because the plugin is embedding an external control from Google, I don't have full control over its behavior. As such it inherits certain quirks. This makes the solution less than ideal for situations where near 100% uptime must be assured. In that case you're still better off just letting the user download the file rather than trying to embed it inline.

    Hope that brings some clarity. Regarding the specific IE8 issue, all I can say is that IE8 was notoriously problematic for the viewer, and it was the reason the "enhanced" version was ever implemented in the first place, a solution that worked around most of the problems most of the time. It is certainly not flawless, but the extensive errors you reported are new to me. Perhaps the situation with IE8 and Google's viewer is in fact getting worse rather than better. I'm guessing you're on XP, otherwise IE9 would be your option?

    Kevin

  7. pragya
    Member
    Posted 3 years ago #

    hi i'm getting error with wp-symposium plugin
    in Mozila , and all other browser too
    Error: jQuery("#symposium_current_user_avatar").html() is null
    Source File: http://localhost/WordPress/wp-content/plugins/wp-symposium/js/symposium.js?ver=3.1.3
    Line: 2167

    actually when i clicked on forum page then select support category and select the topic and wanted to add reply using reply button , but it is showing this error and could not add reply to that topic

    please help me

  8. k3davis
    Member
    Plugin Author

    Posted 3 years ago #

    Hi pragya,

    This thread relates to a different plugin (and I'm not familiar with the one you're struggling with) so this is probably not the best place to ask your question. You may want to take a look or post here:

    http://www.wpsymposium.com/discuss/

    Hope this helps.

    Kevin

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic