WordPress.org

Ready to get started?Download WordPress

Forums

Error 500 messages (10 posts)

  1. f1f
    Member
    Posted 5 years ago #

    I'm using WordPress 2.7 and for several weeks now my site is giving me Error 500 messages. If I go into SSH and type 'ps faux' I discoger there are loads of index.php processes running. Here's a sample:

    1001     29236 26.0  1.9  30848 19504 ?        S    10:02   0:00 /usr/lib/cgi-bin/php5 /kunden/homepages/36/d222495733/htdocs/index.php
    1001     29230  2.4  1.9  30508 19132 ?        S    10:02   0:00 /usr/lib/cgi-bin/php5 /kunden/homepages/36/d222495733/htdocs/index.php
    1001     28401  0.5  1.9  30508 19124 ?        S    10:01   0:00 /usr/lib/cgi-bin/php5 /kunden/homepages/36/d222495733/htdocs/index.php
    1001     28331  0.3  1.9  30508 19208 ?        S    10:01   0:00 /usr/lib/cgi-bin/php5 /kunden/homepages/36/d222495733/htdocs/index.php
    1001     28363  0.4  1.9  30508 19256 ?        S    10:01   0:00 /usr/lib/cgi-bin/php5 /kunden/homepages/36/d222495733/htdocs/index.php
    1001     28361  0.4  1.9  30848 19488 ?        S    10:01   0:00 /usr/lib/cgi-bin/php5 /kunden/homepages/36/d222495733/htdocs/index.php
    1001     28376  0.4  1.9  30508 19124 ?        S    10:01   0:00 /usr/lib/cgi-bin/php5 /kunden/homepages/36/d222495733/htdocs/index.php

    Here's what the error log showed up in the moments leading up to one such crash:

    [Tue Jan 27 08:05:02 2009] [debug] mod_rewrite.c(1719): [client 69.246.173.248] mod_rewrite's internal redirect status: 0/10.
    [Tue Jan 27 08:05:02 2009] [warn] mod_mime: analyze_ct: cannot get media type from 'x-mapp-php5'
    [Tue Jan 27 08:05:02 2009] [warn] (2)No such file or directory: mod_mime: analyze_ct: cannot get media type from 'x-mapp-php5'
    [Tue Jan 27 08:05:02 2009] [warn] mod_mime: analyze_ct: cannot get media type from 'x-mapp-php5'
    [Tue Jan 27 08:05:08 2009] [warn] mod_mime: analyze_ct: cannot get media type from 'x-mapp-php4'
    [Tue Jan 27 08:05:08 2009] [warn] mod_mime: analyze_ct: cannot get media type from 'x-mapp-php4'
    [Tue Jan 27 08:05:08 2009] [warn] mod_mime: analyze_ct: cannot get media type from 'x-mapp-php4'
    [Tue Jan 27 08:05:08 2009] [warn] mod_mime: analyze_ct: cannot get media type from 'x-mapp-php5'
    [Tue Jan 27 08:05:08 2009] [warn] mod_mime: analyze_ct: cannot get media type from 'x-mapp-php5'
    [Tue Jan 27 08:05:08 2009] [warn] (2)No such file or directory: mod_mime: analyze_ct: cannot get media type from 'x-mapp-php5'
    [Tue Jan 27 08:05:08 2009] [warn] mod_mime: analyze_ct: cannot get media type from 'x-mapp-php5'
    [Tue Jan 27 08:05:09 2009] [info] [client 125.165.168.226] (32)Broken pipe: client stopped connection before send mmap completed
    [Tue Jan 27 08:05:11 2009] [debug] mod_rewrite.c(1719): [client 66.249.66.75] mod_rewrite's internal redirect status: 0/10.
    [Tue Jan 27 08:05:11 2009] [warn] mod_mime: analyze_ct: cannot get media type from 'x-mapp-php5'
    [Tue Jan 27 08:05:11 2009] [warn] (2)No such file or directory: mod_mime: analyze_ct: cannot get media type from 'x-mapp-php5'
    [Tue Jan 27 08:05:11 2009] [warn] mod_mime: analyze_ct: cannot get media type from 'x-mapp-php5'
    [Tue Jan 27 08:05:13 2009] [info] removed PID file /var/run/apache-perf.pid (pid=15587)
    [Tue Jan 27 08:05:13 2009] [notice] caught SIGTERM, shutting down

    Any ideas?

  2. f1f
    Member
    Posted 5 years ago #

    Still struggling with this. Got a bit more information from another error log:

    25/01/2009 18:38	"/homepages/36/d222495733/htdocs/wp-includes/functions.wp-styles.php:
          25"	() is_a(): Deprecated. Please use the instanceof operator
    25/01/2009 18:38	"/homepages/36/d222495733/htdocs/wp-includes/functions.wp-scripts.php:
          91"	() is_a(): Deprecated. Please use the instanceof operator
  3. toddfox
    Member
    Posted 5 years ago #

    are you running WP Super Cache? (point 9)
    http://wordpress.org/extend/plugins/wp-super-cache/installation/

  4. f1f
    Member
    Posted 5 years ago #

    I am, though at one point I switched it off and used hypercache instead.

    However that doesn't necessarily mean this isn't part of the problem. Thanks for the tip, I'll look into this.

  5. f1f
    Member
    Posted 5 years ago #

    How do I check that Apache is configured to use the relevant modules?

  6. f1f
    Member
    Posted 5 years ago #

    I've uninstalled SuperCache again (following the instructions in its readme file). However I'm still getting these 500 Errors.

    The latest ones occured just now while I was editing some old posts and adding them to a new category. I edited perhaps 15 posts and got the errors at least twice.

  7. BernardBorealis
    Member
    Posted 5 years ago #

    usually these problems are caused by a plugin. Try disabling all of your plugins for a while and see if you still have the problem. Try switching your theme to the default theme, too.

  8. f1f
    Member
    Posted 5 years ago #

    Thanks for the comment. I have previously disabled and re-enabled various plugins and this hasn't revealed the problem. I'm going to try changing themes later, but as that will stop some of the site from being available I need to do some preparation before I can flick that switch.

    In the meantime from looking at these threads I wondered if the problem might be related to Permalinks:

    http://wordpress.org/support/topic/232770
    http://wordpress.org/support/topic/165611?replies=19

    I have been using the 'Day and Name' (http://www.siteurl.com/2009/03/03/sample-post/) form of Permalinks.

    I switched to the default setting and tried to see if I could provoke the 500 Errors again - I edited lots of posts at once, changed category and tag assignments en masse, all the sorts of things that usually causes the errors, and nothing happened. I spent perhaps an hour trying to provoke an Error 500.

    So I switched back to the 'Day and Name' permalinks and tried to cause the errors again, and still nothing.

    So I don't know whether:

    (a) The Permalinks weren't the cause of the errors in the first place.
    (b) The Permalinks were the cause of the errors, and briefly switching between Default and 'Day and Name' permalinks somehow cleared the fault.
    (c) The Permalinks were the cause of the errors, and the problem isn't fixed, it just hasn't happened yet today.

    I guess I'll know next time I'm trying to get something on the site in a hurry and I get a 500 Error and fling my computer across the room. Until I can get through a week without having to go into SSH and clear dead processes to rectify a 500, I'll consider this problem unresolved.

  9. f1f
    Member
    Posted 5 years ago #

    Sure enough. for the past 20 minutes the site has been running very slowly. I had a look in SSH and multiple instances of index.php processes were stacking up (as described in my first post). It took several attempts (using kill -9 -1) to get them to all clear, and now the site is running OK again.

    So we can rule out option (b) from the above. I'm going to switch back to default permalinks now and see whether any more errors happen.

  10. f1f
    Member
    Posted 5 years ago #

    I switch back to default permalinks and a few minutes later the site returned to normal.

    Can I therefore conclude that it was definitely the permalinks causing the problem?

    Also, what do I need to do to make the site work with the 'Day and Name' permalinks again? I'm going to lose a massive amount of traffic and search ranking if I can't restore them.

Topic Closed

This topic has been closed to new replies.

About this Topic