WordPress.org

Ready to get started?Download WordPress

Forums

Magento WordPress Integration
[resolved] Error 500 (Internal Server Error) (12 posts)

  1. zoan
    Member
    Posted 1 year ago #

    Followed the instructions on updating duplicating and updating functions.php file in Magento's app directory. Installed plugin on 3.4.2 install. When I enter the path to the Mage.php file I receive a blank Settings page along with a 500 error.

    Magento (Magento ver. 1.7.0.2) isntalled within sub-directory of the WordPress install.

    http://wordpress.org/extend/plugins/magento-wordpress-integration/

  2. jeremyBass
    Member
    Posted 1 year ago #

    I have the same issue. Is there a fix or workaround? What did you do zoan?

    Magento ver. 1.7.0.2
    did the "if(!function_exists('__')) { function __() { return Mage::app()->getTranslator()->translate(func_get_args()); } }" change

    Change the path in WP for the Mage.php path and bam setting are blank, and the WP site is down.

    Thanks -Jeremy

  3. jeremyBass
    Member
    Posted 1 year ago #

    Ok figured it out.. fell little stupid for it thou but for me it was that i did literally what install said to which was replace the line at 90 which was not the whole function lol.. may be for hijacking

  4. jamesckemp
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Jeremy, could you confirm what you did here? Did you replace line 90 with the code, and not the actual function? Just means I can make it clear for others

  5. spyhunterx
    Member
    Posted 1 year ago #

    Hey. Seems like I'm not the only one with this problem. IFgthis is not going to work anytime soon, like by tomorrow, I'm most definitely going to demand a refund for that add-on I purchased from you.

  6. jamesckemp
    Member
    Plugin Author

    Posted 1 year ago #

    Threats are not the best way to receive help. Integrating these two platforms is a very complex procedure and I've made it as simple as possible, of course there is still room for human error during setup.

    Let me know what youve done to set it up, provide some code and I'll see what I can do to fix it.

  7. spyhunterx
    Member
    Posted 1 year ago #

    I most certainly apologize. My client is going to kill me.

    I've set it up in the order of instructions 1-6, as instructed. When the plug-in is enabled, the setting page for it, including the site it self goes blank. Similar to Jeremy Bass's problem. I'm willing to pay extra if I have to. I need this by Tuesday morning. I already paid for your plug-in. What can I do ?

    Again, sorry for the grumpiness earlier.

  8. jamesckemp
    Member
    Plugin Author

    Posted 1 year ago #

    If you can send me FTP and Mage/WP logins via the email address on http://www.magentowp.com I will have a look at the issue.

  9. spyhunterx
    Member
    Posted 1 year ago #

    I will do that right now.

  10. spyhunterx
    Member
    Posted 1 year ago #

    Sent you an email as requested.

    Greatly looking forwards to your reply !

  11. jamesckemp
    Member
    Plugin Author

    Posted 1 year ago #

    This has now been solved. Not sure what went wrong, but I installed the plugin as per my instructions on http://www.magentowp.com and it all worked fine.

  12. spyhunterx
    Member
    Posted 1 year ago #

    Yes, James. You are right. It turns out that I improperly installed the plug in, by not following the instructions in the correct order. I advise everyone to avoid this error by simply installing the plug-in in an order fashion.

    I gave you access to my web sever to fix the problem, and you eventually did. I would like to Thank You so much for doing that man !

    Awesome plug-in ! Thanks !

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic