WordPress.org

Ready to get started?Download WordPress

Forums

Error 500 (9 posts)

  1. jbeltran
    Member
    Posted 5 years ago #

    Hi,

    I uploaded my WordPress site to a 1and1 server, and I'm getting this error whenever I try to access pages:

    Error 500 - Internal server error

    An internal server error has occured!
    Please try again later.

    The home page and admin works fine, but everything else brings up that error. I tried changing the .htaccess file as well as the file permissions (as suggested by various sites) but it seems that neither work. Does anyone know how I can resolve this?

    Thanks

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Try resetting your custom permalinks to the default setting. If that works, then try reading:
    http://codex.wordpress.org/Using_Permalinks
    before setting a custom permalink structure back up again.

  3. mtrethowan
    Member
    Posted 5 years ago #

    My comment page functions give me this err or also. I am hosting my own WordPress blog. Is this fix the same for me too?

  4. mtrethowan
    Member
    Posted 5 years ago #

    To give a little more info, I should say the when someone comments, then presses the submit comment button, this error comes up.

    When I administer the site, the comment is waiting for approval. When I click the check box, select approve, then click apply, I also get error 500. The comment is never lost and is available for viewing.

    So far, these are the only times I get these errors.
    Thanks

  5. bluec.info
    Member
    Posted 4 years ago #

    I find the answer...

    Just Edit .htaccess
    with

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    and CHMOD this files in permission : 444 (if you are on 1&1 !)

    it's a problem about your php version. Enjoy, it's working for me!!!

  6. emergencypower
    Member
    Posted 4 years ago #

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    adding this to my .htaccess worked!!!

    I am on 1&1 by the way. Have not done the CHMOD not sure what files need to change, all of them?

    Either way just editing the .htaccess seems to have fixed it.

  7. jwahkan
    Member
    Posted 4 years ago #

    Thanks for this solution!

    I was having a similar problem with WP and 1&1 after just moving my WP install from another host.

    This solution worked for me and solved all my access problems.

    Thanks!

  8. yankeefan2225
    Member
    Posted 4 years ago #

    This thread should be added to the codex or something, it's an immediate fix.

    Thank you so much!

  9. baydream
    Member
    Posted 4 years ago #

    thanks, I will 1and1 and couldnt find any reference to this file, so created it with text wrangler and ftp it straight in now things such as my incoming links now work

    cheers

Topic Closed

This topic has been closed to new replies.

About this Topic