WordPress.org

Ready to get started?Download WordPress

Forums

Post By Email
Error 404 When Check (8 posts)

  1. KristoferB
    Member
    Posted 5 months ago #

    So I was looking for a way to post by email. Thought I would try this plugin.

    Configured it to pop3

    I get either:
    Please wait 5 mins to check mail again!
    or
    An error occurred: Error connecting to POP3 server. (which I actually only got twice and that's only when I enable SSL)

    When I press 'check now' it will give me Error 404 on the site sometimes and sometimes it gives the Please Wait message.

    I don't understand what I'm doing wrong.

    I switched to IMAP settings for my email and things got worse...

    I got this: Catchable fatal error: Argument 3 passed to Horde_Imap_Client_Exception_ServerResponse::__construct() must be an instance of Horde_Imap_Client_Interaction_Server, integer given, called in /.../wp-content/plugins/post-by-email/include/Horde/Imap/Client/Socket.php on line 3946 and defined in /.../wp-content/plugins/post-by-email/include/Horde/Imap/Client/Exception/ServerResponse.php on line 55

    http://wordpress.org/plugins/post-by-email/

  2. KristoferB
    Member
    Posted 5 months ago #

    I should note that I can use Postie and it works with my email settings just fine, but that's done manually as Cron is disabled on the server.. I was hoping I could use this plugin as a workaround for that..

  3. Kat Hagan
    Member
    Plugin Author

    Posted 5 months ago #

    Hi! Sorry you're having trouble with the plugin. What PHP version are you using? I've seen some other folks having trouble on PHP 5.2, which I'm hoping to fix in the next version.

    Seeing a 404 is super weird. What URL does it try to load that gives you a 404 page?

    Did you change your port when you enabled SSL? SSL usually requires a different port number.

  4. KristoferB
    Member
    Posted 5 months ago #

    PHP Version 5.2.17

    the url is: wp-admin/tools.php?page=post-by-email&check_mail=1

    and it shows the site header, menu and then:

    ERROR 404

    The page you are looking for does not exist.

    As far as SSL, no I didn't change it.. it works fine in Postie without using SSL so i don't think that's an issue..

  5. KristoferB
    Member
    Posted 5 months ago #

    Hello? Anything?

  6. Kat Hagan
    Member
    Plugin Author

    Posted 5 months ago #

    I'm looking into it. The issues with PHP 5.2 are myriad; I'm rewriting some things pretty significantly for the next release, which will hopefully make it less of an issue, but that won't be done for a few weeks at the earliest.

    Is there any chance you can update to PHP 5.3? That's the easiest solution right now.

    The reason I mentioned the ports for POP3+SSL is that "Error connecting to the mail server" message means something was misconfigured. When you enable SSL, you do need to make sure to change the port number (mail servers use different ports for secure vs. insecure connections).

    Also, the following info would help me track down the problem--

    WordPress version (e.g. 3.6, 3.7)
    Post By Email version (hopefully 1.0.4b right now)
    Mail server (e.g. Gmail, Yahoo, hosted (which host?), self-hosted (what software))

    Thanks.

  7. KristoferB
    Member
    Posted 5 months ago #

    WordPress is the latest version, whichever that is now.. I always keep my sites up to date with that as soon as the update comes out

    Post by email version is the one there for download, unless you changed it in the past two days as I just downloaded it two days ago..

    It's my own mail server, or one of my sites mail servers really through GoDaddy.. has pop3 and impap it's pop.securesever.net for the pop3 email (I set it up through one of my own sites for testing purposes to try and get post by email up and running one way or another)

    as far as SSL, I don't think it's an issue as it works without SSL just fine using Postie plugin

    as far as upgrading to PHP 5.3.. it's a possibility but it's not my site, it's a friend of mine and I do the design and maintenance on it and anything else he needs like setting up post by email which I'm trying to do for him and all of the writers on the site..

    I can see if he can get his host to upgrade him to PHP 5.3 though

  8. KristoferB
    Member
    Posted 5 months ago #

    Ok.. I got it updated to php 5.3.27

    When I press check now I still get the error 404 sometimes.

    But I usually get the 'Please wait 5 mins' message and it doesn't grab the post.

    I got it to work once all by itself, I didn't press the check now button, it just did it automatically and it got the post from the email but it scheduled it and didn't post it.

    The scheduling isn't a good thing as the site has a bug apparently where scheduling is concerned and I can't figure out how to fix it. Scheduling just doesn't work on the site, it always misses the schedule.

    Right now I have two emails sitting in the mailbox and it's not working to post them.

    When I press Check now sometimes I get the 404 error and sometimes I get the 'Please wait' message..

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.