WordPress.org

Ready to get started?Download WordPress

Forums

Error 404 on posts in new 2.6 ?? (16 posts)

  1. jinge
    Member
    Posted 6 years ago #

    I recieved a lot of mail because pepole CANT link to bloggposts. When I click on the subject: http://jinge.se/index.php/internet/wordpress-26-slappt.htm

    I recieve_

    The page you requested is no longer here [error 404]

    What the FUCK ??

  2. Anonymous
    Unregistered
    Posted 6 years ago #

    The problem is in permalinks! Anybody knows how can solve that?

  3. jinge
    Member
    Posted 6 years ago #

    Now I cant login... :-(

  4. dolemite
    Member
    Posted 6 years ago #

    I can't login either. I tried going back to the previous version and I still can't login. Last time I'm a first adapter for a new version.

  5. acheashadow
    Member
    Posted 6 years ago #

    Ive got the exact same problem!

  6. metalmd
    Member
    Posted 6 years ago #

    Well I don't know how to fix it. I checked my permalinks and they are set to exactly the way it appears in the post.

    How do I fix?

  7. Ben Pollock
    Member
    Posted 6 years ago #

    Me, too. I upgraded today, Saturday 19 July 2008, to 2.6 from last month's 2.5.x, and now every internal link, for example to categories and jumps etc., comes up with a 404. I've tried three themes and the same thing happens so it's not the theme matching up. The 404 message on each of them is worded somewhat differently, but all come up blank except for the blog's index or home page. I've tested this at home and at work, so different servers and browsers.

    I did the WordPress upgrade using Fantastico from the Control Panel of Hosting Matters. I've never had this problem before, and I've been using WordPress, upgraded using Fantastico, for 2.5 years.

  8. DCThree
    Member
    Posted 6 years ago #

    Hello guys,

    I had the same problem when upgrading to 2.6...

    it is permalink based... for some reason they get extended, which is why your links arent working properly and you receive a 404...

    My site (DCThree), had this added to the end of the permalink: %e2%84%a2

    so, you need to change the name of your permalinks back to their original format... and then remember to save both the permalink and also the actual page that you are editing... this should fix yur problems...

  9. Ben Pollock
    Member
    Posted 6 years ago #

    DCThree: Questions. Do I need to reset all 400-something of my years of posts to the default SQL style (if that's what it is)? 2) Should I, because the permalink including the titles is very handy -- for readers and me -- and then wait for WordPress to fix this in the next day or two or six?

  10. DCThree
    Member
    Posted 6 years ago #

    longhand: you should not need to reset your x years of posts... so please do not do that. You should simply reset the permalink of your posts or pages, as the reason they are receiving a 404 is because you are literally calling up a page that is not there - as the link has been changed... reverting the link back to its original state should fix the problem. At least it did for me...

    However, here is the bad news... users have complained about a flurry of additional problems with the 2.6 install, so just go ahead and search the forums for 2.6, permalinks or new install problems, and you should find your answer...

  11. Ben Pollock
    Member
    Posted 6 years ago #

    Ah, thanks, DCThree, the default permalink restores nearly all linking functionality. Links to some but not all category names still come up with a 404, but I can live with that for a while,, waiting for 2.6.1.

  12. metalmd
    Member
    Posted 6 years ago #

    Ok, DCThree, what do you mean reset my permalinks. I have reset them, at least I have set to the default, saved it, and then used the same permalink structure, index.php/%year%/%monthnum%/%day%/%postname%/, as before.

    But it still won't link to those posts, nor will it link to the comments either. I get an 'error 404' message in both cases.

    So can you please elaborate more clearly what you mean by resetting the permalinks?

  13. stickybomb
    Member
    Posted 6 years ago #

    currently the default permalinks are the only ones working. Custom permalinks are not functioning at the moment

  14. donaldkelly
    Member
    Posted 6 years ago #

    You all seem to know this by now, but the problem is permalinks. The cause of this may have been that you over-wrote your existing .htaccess file, which allowed the use of mod_rewrite when you uploaded the new release of WordPress to your server(s). As some hosts (including mine.) by default have this option disabled (for some reason.)

    Try uploading / making a new .htaccess file or restoring to the default permalink structure (non-"pretty" for example http://yoursite.co.uk/blog/p=242 or something of the like.) and then saving that. If that works then try going back to WP-Admin and changing back to your selected permalink type. If links within your blog begin to return 404 Errors again then it may be worth changing back to the non-pretty type and waiting for 2.6.1, Which is said to resolve this problem on most servers. Your hosting account may also come with an option for modifying your .htaccess file from within your control centre. If this is the case then enable MOD_REWRITE for the directory that WordPress is installed in.

    -DK | London, UK |

  15. metalmd
    Member
    Posted 6 years ago #

    Just eliminate the index.php attribute from you custom permalinks structure, and everything will work fine. Even linking from search engines.

  16. jason-morrison
    Member
    Posted 6 years ago #

    Check out the end of this thread:

    http://wordpress.org/support/topic/188977

    Worked for me.

Topic Closed

This topic has been closed to new replies.

About this Topic