WordPress.org

Ready to get started?Download WordPress

Forums

Error 404 on multi site, windows (9 posts)

  1. mfayaz
    Member
    Posted 2 years ago #

    In the past three days I have read/tried several methods on this forum and sadly none is working for me so I finally gave up and here I am..

    Hosting: Godaddy, Windows deluxe, IIS: 7.0

    I have wordpress multi site configured and the network admin is working fine. main website is working fine too. but although the network sites dashboards works, none of the their websites seems to work and throws a 404 error.

    since I'm on windows I dont have a .htaccess file and have modified my web.config file a thousand times but without success.

    here's my current web.config file

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
            <rewrite>
                <rules>
                    <rule name="WordPress Rule 1" stopProcessing="true">
                        <match url="^index\.php$" ignoreCase="false" />
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 2" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?files/(.+)" ignoreCase="false" />
                        <action type="Rewrite" url="wp-includes/ms-files.php?file={R:2}" appendQueryString="false" />
                    </rule>
                    <rule name="WordPress Rule 3" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
                        <action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
                    </rule>
                    <rule name="WordPress Rule 4" stopProcessing="true">
                        <match url="^" ignoreCase="false" />
                        <conditions logicalGrouping="MatchAny">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
                        </conditions>
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 5" stopProcessing="true">
                        <match url="(^[_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)" ignoreCase="false" />
                        <action type="Rewrite" url="{R:2}" />
                    </rule>
                    <rule name="WordPress Rule 6" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
                        <action type="Rewrite" url="{R:2}" />
                    </rule>
                    <rule name="WordPress Rule 7" stopProcessing="true">
                        <match url="." ignoreCase="false" />
                        <action type="Rewrite" url="index.php" />
                    </rule>
                </rules>
            </rewrite>
        </system.webServer>
    </configuration>
  2. mfayaz
    Member
    Posted 2 years ago #

    FYI:
    I have setup multisite with subdomain & I have created a wildcard DNS too.

    I asked godaddy staffs if my wildcard is working and..

    Your domain's wildcard DNS is setup properly and is directing all subdomain inquiries to the proper hosting IP address. The issue seems to remain with your scripting, related to the web.config file. As previously recommended, that is not something we provide assistance with. I recommend you utilize the third-party information we referenced in previous correspondence for additional assistance in this matter. Let us know if we can assist you in any other way.

  3. mfayaz
    Member
    Posted 2 years ago #

    lastly, if there is absolutely no solution for this on Windows, I will change my OS to linux

  4. George Vrettos
    Member
    Posted 2 years ago #

    I suspect there is a problem with the
    Options -Indexes
    option in your configuration file because I've come across a similar problem today.
    Although it is not good for security to disable it, try commenting it out and check it this way.

  5. There isn't "no" solution,but I'd really switch to Linux anyway. Works better with this stuff.

  6. jrcole
    Member
    Posted 2 years ago #

    We are using ISAPI_rewrite with IIS 6 and youre rewrite rules match our .htaccess. However, we are using the subdirectory approach for multisite.

    We do occasionally have issues with the Permalinks setting. I guess WordPress doesn't detect the .htaccess and tries to insert index.php into the permalink structure. When this happens, the root site will still work but none of the subsites.

    All that to say, check Permalinks for individual sites as well as the root site (/wp-admin/network/site-settings.php?id=1).

    Good luck.

  7. mfayaz
    Member
    Posted 2 years ago #

    ok I changed my OS to linux, still stuck on errors..

    main site (example: mysite.com) is working but subdomain sites (example: shop.mysite.com) throws errors..

    http://shop.mysite.com/wp-admin/ (500 Internal Error)

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    http://shop.mysite.com/ 403 Forbidden

    You don't have permission to access / on this server.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    any ideas?

    here is my .htaccess

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>
    
    # END WordPress
  8. mfayaz
    Member
    Posted 2 years ago #

    FYI
    here is a link to my site
    mywebiste.com

    subdomain
    shop.mywebiste.com

    I have a wildcard DNS record. I even created the subdomain manually

  9. DNS isn't working.

    http://www.whatsmydns.net/#A/shop.zintle.com/

    That should give you the same results for your other site.

Topic Closed

This topic has been closed to new replies.

About this Topic