WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] ERROR 404 "Not Found": Cannot Access Multisite Admin Areas (19 posts)

  1. Sirocki
    Member
    Posted 1 year ago #

    I am unable to access the admin areas of several sites on my multisite network, in addition to the network admin area. I am, however, able to access only one site (which is very strange). After logging into any of the admin areas, I am immediately taken to an Error 404 page, reading:

    Error 404: This page was not found, page is missing or removed

    This has been doing this for probably the past month or so. It happened out of nowhere; everything was fine before. I currently am running WordPress 3.5.1. I need help with this urgently. Any help is desperately needed.

    - Marlon

  2. What does the 404 look like?

    Does it look like your main site or your child site or your server?

  3. Sirocki
    Member
    Posted 1 year ago #

    Hi. It looks like the main site, which in my case is: http://marlon.co — Regarding the child sites when the 404 occurs it looks like their respective sites. If you go to my main site, you can see it. Sometimes the site begins to load as normal, and then it quickly jumps to "marlon.co/not-found" or sometimes "marlon.co/false" and then loads the 404 page.

  4. *blink* Huh. Turn off all your plugins for starters.

  5. Sirocki
    Member
    Posted 1 year ago #

    I am unable to do that, as I cannot access the network admin area (nor individual site admin areas). I would have to completely remove them from the host server, something of which I do not want to do unless you feel that is definitely the issue...

  6. jkhongusc
    Member
    Posted 1 year ago #

    FYI - I found that if I had a bad plugin that does not allow me to access the admin area, I rename the plugin directory.

    <base>/wp-content/plugins
    to
    <base>/wp-content/plugins-bak

    If you rename your plugins directory and still cannot access the admin area, then something else is causing the problem. If renaming allows you to access the admin area, then you can do a few things: 1) move plugin back a few or one at a time 2) remove the last plugin(s) that you added

  7. Sirocki
    Member
    Posted 1 year ago #

    Awesome idea and advice. After trying that however (renaming the plugin directory), I'm still not able to access the admin area.

  8. jkhongusc
    Member
    Posted 1 year ago #

    Then your problem is most likely not due to a plugin.

    I just took a look at your main site http://marlon.co/ and I get redirected to http://marlon.co/false which results in a 404 error. IMO, there is a problem with your content or theme. I noticed if I removed this line from your main page, that the site loaded fine:

    [ Moderator note: please wrap code or log lines in backticks or use the code button. ]

    <script type='text/javascript' src='http://marlon.co/wp-content/themes/flare/js/prettyPhoto/js/jquery.prettyPhoto.js?ver=3.5.1'></script>
  9. Sirocki
    Member
    Posted 1 year ago #

    Thanks, I appreciate you taking a look at it. So to solve that, should I try renaming the theme (Flare) folder directory since I can't access the admin settings to disable it, or what do I do?

  10. jkhongusc
    Member
    Posted 1 year ago #

    Fixing/debugging this problem is beyond my knowledge. It seems to be an issue with your theme, or at minimum a particular component (prettyPhoto).

    Renaming your theme folder would probably make WP admin console not available. I would recommend renaming the problem component for example rename:
    <base>/wp-content/themes/flare/js/prettyPhoto
    to
    <base>/wp-content/themes/flare/js/prettyPhoto_bak

    In that case it should only break your photos.

  11. Sirocki
    Member
    Posted 1 year ago #

    Ok. I did a test to see if it was the theme by renaming the theme (Flare) directory; the problem still occured.. so it may be the content. I have to somehow figure out how to remove that line of code without being able to access the admin area.

  12. jkhongusc
    Member
    Posted 1 year ago #

    Changing the theme directory name fixed the problem with http://marlon.co/

    IMO, you have a different problem that prevents you from accessing http://marlon.co/wp-admin. For example, I tried accessing http://marlon.co/readme.html and it was not found. I think your httpd configuration or .htaccess has problems.

  13. Sirocki
    Member
    Posted 1 year ago #

    Wow that was weird. You're right: http://marlon.co is working now, and I didn't even realize that until you told me. I had actually renamed it and then changed it back to it's original name and now that works. Yet you're also right, I'm still unable to access the admin area. Is there a way to fix/reset/troubleshoot the .htaccess to solve this? I'm not that knowledgeable regarding that.

  14. jkhongusc
    Member
    Posted 1 year ago #

    You should post your .htaccess here. Are you running multisite sub-domain or sub-directory. Also make sure all your plugins are disabled; for example by renaming your plugin directory. I am not convinced it is a htaccess problem, but that is a good place to start.

    Also I do not know why you do not have http://marlon.co/readme.html. I have that in my WP installation directory: <wp_base>/readme.html Can you verify that file exists or did you clean out files?

  15. Sirocki
    Member
    Posted 12 months ago #

    I'm running a sub-domain multisite. I thank you again for helping me out with this. I checked for the readme.html and I do indeed have that, located in <wp_base>/readme.html — Here is my current .htaccess file:


    [Please use a pastebin for that much code per http://codex.wordpress.org/Forum_Welcome#Posting_Code ]

  16. jkhongusc
    Member
    Posted 12 months ago #

    Well I see what your problem is. You have a plugin, Better WP Security (http://wordpress.org/plugins/better-wp-security/), that you installed and configured; but you probably do not understand what it changed.

    I do not use that plugin. You have configured it to obscure/hide a number of things. Can you log into your WP admin console now? If not, I would recommend backing out Better WP Security changes. For instance, I would backup your current .htaccess file and create a new .htacess that has the default WP multisite settings. You can always reinstall and reconfigure Better WP Security plugin again later.

  17. Sirocki
    Member
    Posted 12 months ago #

    Ok. I actually had a feeling that may had been the problem. No I still am unable to access the admin console. Would you advise for me to simply remove the coding section that Better WP Security created on the .htaccess file, leaving the original coding as well as the W3 Total Cache coding? Or just copy the "Begin WordPress" section & create the new file from that?

  18. Sirocki
    Member
    Posted 12 months ago #

    Also, should I rename (or delete) the Better WP Security as well, in addition to that?

  19. Sirocki
    Member
    Posted 12 months ago #

    That worked! I removed the Better WP Security coding in the .htaccess file and I am now able to access the admin areas network-wide. I will re-enable some of the functions from the security plugin and if it happens to do it again I'll isolate the change and make sure I do not use that specific one. Thank you GREATLY for all of your time & help with this. I truly appreciate it.

Topic Closed

This topic has been closed to new replies.

About this Topic