WordPress.org

Ready to get started?Download WordPress

Forums

Error 404 after updating to 3.5 and Error 403 on Dashboard (8 posts)

  1. miskettie
    Member
    Posted 1 year ago #

    Hi

    I posted earlier, as my server had automatically updated my website. http://www.maverickartspublishing.com but have had some further/different problems now.

    First of all I couldn't access my sites at all. I had to change the permissions to gain access.

    Then once I got in I was prompted to update my database, which I did.

    Then as you can see my site is not showing any pictures (or anything). Even on the dashboard the WP logo is missing from the top left corner. On the website the error log says:

    Failed to load resource: the server responded with a status of 404 (Not Found)

    On the dashboard, the error log says:

    Failed to load resource: the server responded with a status of 403 (Forbidden)

    I have looked at the master 3.5 post thing and have:
    -Changed/updated the permalinks
    - Looked at the .htaccess and have this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    - reinstalled 3.5
    - Tried the Twenty-Twelve theme, but no change
    - Contacted my server (Dreamhost) who seem to have had problems earlier today, but they are now resolved, but probably not related as didn't have any effect on my website. They have not replied.
    - I tried reinstalling with the most recent version of my theme. No change (so reverted back to old one).
    - Disabled all plugins. Then I deleted them one at a time to see if any change and was none. I have very few plugins anyway.

    And so with my very limited website knowledge...i'm stumped. Any help would be greatly appreciated.

  2. tomontoast
    Member
    Posted 1 year ago #

    Could be due to many things try the fixes found by searching google http://www.google.com.my/search?q=403+wordpress

  3. miskettie
    Member
    Posted 1 year ago #

    I had tried loads of fixes previously...

    However I have just had a relook at permissions and by making many of them 777, the website has now returned. However from what I have read it is not good to have 777 permissions....so what do I do now?

    Thanks

  4. tomontoast
    Member
    Posted 1 year ago #

    Its not really bad, just a little bit insecure.

    Read http://codex.wordpress.org/Changing_File_Permissions

  5. miskettie
    Member
    Posted 1 year ago #

    Thanks for your help today tomontoast. I have managed to change the permissions to being a bit lower. Just don't know why it had to be done. Thankfully my whole site is how it was before.

    Thanks

  6. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    miskettie sorry about all the delays.

    We're looking into what caused that weird error on your site, and I think we know what's wrong. It looks like the folder permissions got weird. You should be able to set the wp-content/themes folder to permissions 755 to fix this, which is safer than 777.

    If you need any help, just give a shout.

  7. miskettie
    Member
    Posted 1 year ago #

    Hi Mika

    No problems - I worked it out eventually and have now set all to 755 and it is all working.

    Thanks though

  8. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    Sweet :)

    The engineers looked into our upgrade script and we're making sure something like this won't happen again.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags