WordPress.org

Ready to get started?Download WordPress

Forums

Error 403 - I'm spamming my own site? (15 posts)

  1. intcon
    Member
    Posted 1 year ago #

    Hi all...

    I've been working on adding a comment form to a test site...and when I tested the form I got this page

    Your IP address has been blacklisted because a larger number of spam comments originated from the same source.

    Please refer to ten-fingers-and-a-brain.com/top-spammers.html for a more detailed explanation.

    what on earth is that???

  2. intcon
    Member
    Posted 1 year ago #

    anyone have any ideas on this one? is it possibly a coding error i've done?

  3. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Are you running the plugin from ten fingers and a brain?

  4. intcon
    Member
    Posted 1 year ago #

    Not that I'm aware of. I attempted to go to the ten fingers site and it says
    this page is under construction (updated 2010-03-11 20:16 GMT)
    I have no plugin that uses the words top or spammers ....i do have akismet?

  5. intcon
    Member
    Posted 1 year ago #

    So i USED to have block top spammers on the site my blog is hosted under. ( I have 5 sites under one main site) is it possible that has blocked it? and then I looked at the htaccess file under the main site and it says this after the end wordpress

    # BEGIN top-spammers
    <Files wp-comments-post.php>
    Order allow,deny
    allow from all
    
    ErrorDocument 403 '<title>Access denied!</title><style><!-- p,address{margin-left:3em;} span{font-size:smaller;} --></style><h1>Access denied!</h1><p>Your IP address has been blacklisted because a larger number of spam comments originated from the same source.</p><p>Please refer to <a href=http://ten-fingers-and-a-brain.com/top-spammers.html>ten-fingers-and-a-brain.com/top-spammers.html</a> for a more detailed explanation.</p><h2>Error 403</h2><address><span>top-spammers/0.5</span></address>'
    </Files>
    # END top-spammers

    can I delete that line from htaccess? I had deleted top spammers plugin at least a month ago from the main site, and never installed it on the current sub site.

    thoughts?

    carrie

  6. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    This link, http://ten-fingers-and-a-brain.com/ is good.

    Yes, you can delete the entire block after end wordpress.

  7. intcon
    Member
    Posted 1 year ago #

    oh good grief.....well, it took off the error message. =) but now when I leave a test comment, the page goes blank.

    obviously there's bigger issues now. sigh.

  8. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Please post a url.

    And or try adding back
    # BEGIN top-spammers
    <Files wp-comments-post.php>
    Order allow,deny
    allow from all
    </Files>
    # END top-spammers

  9. intcon
    Member
    Posted 1 year ago #

    http://smartasswaitress.com/category/news

    sorry, just got home from work...

  10. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can't get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

  11. intcon
    Member
    Posted 1 year ago #

    I can get in to the dashboard and all other pages, I'm no longer banned anywhere. This was originally a category page, one category fed into the page...and I added in another category so it's now a two category feed page....I'm almost guessing there's some bit of code to where they're leaving a comment but there isn't a piece of code telling the page to post the comments on it? originally it wasn't set up to accept comments...

  12. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    I tried to leave a comment with the same results. Go to that individual page in the control panel and make sure comments are on. Did you do the debug I posted above?

  13. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    There are many validation errors, http://validator.w3.org/check?verbose=1&uri=http%3a%2f%2fsmartasswaitress.com%2fcategory%2fnews some of which have to do with comments. You need to address those.

  14. intcon
    Member
    Posted 1 year ago #

    Yeah, the comments are on.....haven't done the plugin deactivations as of yet...that's next up on my list!

  15. intcon
    Member
    Posted 1 year ago #

    oh dear....the whole page is disaster..

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.