WordPress.org

Ready to get started?Download WordPress

Forums

Error 403 - Forbidden on login (5 posts)

  1. frolix
    Member
    Posted 9 years ago #

    I just installed wordpress, successfully completely the installation process. However, when logging in for the first time, I get a 403 (Forbidden) error. When looking at my ...wp-admin/ directory that the login appears to point to, it appears that permissions are set to 777, including the index.php file in that directory.
    Any ideas?
    -Anders

  2. Provos
    Member
    Posted 9 years ago #

    Try checking the permissions on the directory itself - if you have a shell, chdir to wp-admin and do ls -lad if the permissions aren't at least 755 on the dir, your webserver may have issues. (755 is rwxr-xr-x)

  3. frolix
    Member
    Posted 9 years ago #

    Thanks for the tip. However, it appears that settings for the directory itself are 777 as well.

  4. Smittie
    Member
    Posted 9 years ago #

    I have the same problem. The install script claims that WordPress is successfully installed. However, when I try to log in using the username and password provided by the install script, I get a 403 error. The wp-admin directory permissions are 777. The permissions on all of the WordPress files are 755.
    I'm fairly unimpressed with the WordPress installation. I had a far easier time installing MovableType. The installation instructions could be a lot more complete though, admittedly that wouldn't look as cool and slick as a five line installation instruction set.
    Aloha,
    Smittie

  5. Smittie
    Member
    Posted 9 years ago #

    So it turns out that index.php is not in the default list of file names supported by Apache as index page titles. I added to the Apache config file and WordPress now works as advertise.
    Aloha,
    Smittie

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.