WordPress.org

Ready to get started?Download WordPress

Forums

Tweeple
[resolved] Error 400 (9 posts)

  1. Marcel Bootsman
    Member
    Posted 11 months ago #

    Hi, since today i keep getting Error 400 in the twitter widget:
    "Twitter sent back an error. Error code: 400"

    I have re-authenticated, created a new feed, increase cache time, none seem to help. Help is appreciated.

    http://wordpress.org/extend/plugins/tweeple/

  2. lynnmpearce
    Member
    Posted 11 months ago #

    Hi Guys - I was having the same issue. I discovered it was due to having another plugin installed (WP to Twitter) that also requires a Twitter App to be created and OAuth-orized.

    I have disabled the other plugin and everything is working OK again with Tweeple.

    Do you know if there is any way around this as I would like to have both plugins play happily together. Is the problem because Twitter won't allow 2 Apps to run side-by-side on the site?

    Or is there something that either you guys or the WP to Twitter developer can take care of? Or do you know of a plugin that would automatically send my blog posts to twitter that does play happily with Tweeple?

    Any info much appreciated :-)
    --Lynn

  3. loythegreat
    Member
    Posted 11 months ago #

    Hello Lynn, I have deactivated the WP to Twitter plugin but my site still shows the Error code 400. So maybe this is an issue with the plugin. I hope the author solves this problem.

  4. Jason (Theme Blvd)
    Member
    Plugin Author

    Posted 11 months ago #

    Hello Guys,

    As it looks like you guys have figured out essentially, from looking at the Twitter API error handling, we can surmise that essentially when you get error 400, it means there is some specific issue with the authentication (i.e. "App") you're trying to use to commicate with Twitter API.

    https://dev.twitter.com/docs/error-codes-responses

    Do you know if there is any way around this as I would like to have both plugins play happily together. Is the problem because Twitter won't allow 2 Apps to run side-by-side on the site?

    @Lynn

    I've found the conflict and I've let the author know.

    http://wordpress.org/support/topic/conflict-with-thmoauth-class

    I have deactivated the WP to Twitter plugin but my site still shows the Error code 400. So maybe this is an issue with the plugin. I hope the author solves this problem.

    @loythegreat

    I've got Tweeple running on about 10 live sites, and I can't reproduce any similar issue. Seeing as you're getting the specific 400 error, I would say it most likely also points to something off about your API authentication credentials.

    Are you sure you're putting in the correct Authentication settings?

    Possibly there's something about your Twitter app that has been flagged or blocked for some reason? Have you tried creating a new Twitter app in your Twitter Developer account? And setting up new access tokens?

    Or possibly something wrong with your Twitter account that has maybe been flagged for some reason? Have you tried creating an App and access tokens from another Twitter account?

    Note: Feel free to play around and troubleshoot with this aspect because the Twitter account you connect through for Tweeple realistically is irrelevant.

  5. Joe Dolson
    Member
    Posted 11 months ago #

    The latest version of WP to Twitter, released today, fixes this conflict.

  6. Jason (Theme Blvd)
    Member
    Plugin Author

    Posted 11 months ago #

    Thanks, Joe!

  7. lynnmpearce
    Member
    Posted 11 months ago #

    Thanks @Jason and @Joe :-)

    Downloaded the latest version of WP to Twitter - re-did my Tweeple feeds and everything is looking good.

  8. Marcel Bootsman
    Member
    Posted 11 months ago #

    This topic can be closed. Thanks for the help and advice!

  9. Marcel Bootsman
    Member
    Posted 11 months ago #

    Topic close-post ;-)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.