WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Error 310 (net::ERR_TOO_MANY_REDIRECTS) (9 posts)

  1. gtataje
    Member
    Posted 2 years ago #

    Hi,

    I really hope you can help. I've read other posts in the forum, but haven't been able to find a solution to this problem.

    My main site (http://hostingbarato.biz) is working fine, but the other two new sites (http://switch-marketing.com and http://trampolinereviewsonline.com) are not. I am able to edit them through the admin panel, but keep getting the "Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects." message when I try to visit the sites.

    Part of my wp-config:

    define('WP_ALLOW_MULTISITE', true);
    
    define('SUNRISE', 'on');
    
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'hostingbarato.biz' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    My .htaccess :

    #Protect the .htaccess File
    <files .htaccess="">
    order allow,deny
    deny from all
    </files>
    
    Options +FollowSymLinks
    RewriteEngine On
    RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
    RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
    RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
    RewriteRule ^(.*)$ index.php [F,L]
    
    RewriteEngine On
    #Replace ?mysite\.com/ with your blog url
    RewriteCond %{HTTP_REFERER} !^http://(.+\.)?mysite\.com/ [NC]
    RewriteCond %{HTTP_REFERER} !^$
    #Replace /images/nohotlink.jpg with your "don't hotlink" image url
    RewriteRule .*\.(jpe?g|gif|bmp|png)$ /images/nohotlink.jpg [L]
    
    # disable directory browsing
    Options All -Indexes
    
    deny from 91.224.160.141
    deny from 213.239.214.199
    deny from 184.173.196.194
    deny from 91.207.6.18
    
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Please help!

    Thanks

  2. 1) Did they work BEFORE you mapped domains?

    2) You want to edit this:

    RewriteEngine On
    #Replace ?mysite\.com/ with your blog url
    RewriteCond %{HTTP_REFERER} !^http://(.+\.)?mysite\.com/ [NC]
    RewriteCond %{HTTP_REFERER} !^$
    #Replace /images/nohotlink.jpg with your "don't hotlink" image url
    RewriteRule .*\.(jpe?g|gif|bmp|png)$ /images/nohotlink.jpg [L]

    Add in more lines for each site:

    RewriteCond %{HTTP_REFERER} !^http://(.+\.)?myothersite\.com/ [NC]
  3. gtataje
    Member
    Posted 2 years ago #

    Mika, thank you for the reply.

    1) The sites worked for about a day after I installed WP multi-site, then started getting the error message when trying to visit them.

    2) Is this what I was supposed to do? Still getting the error message on site URLs and published posts/pages, but now I can see post/page previews.

    RewriteEngine On
    #Replace ?mysite\.com/ with your blog url
    RewriteCond %{HTTP_REFERER} !^http://(.+\.)?hostingbarato\.biz/ [NC]
    RewriteCond %{HTTP_REFERER} !^http://(.+\.)?switch-marketing\.com/ [NC]
    RewriteCond %{HTTP_REFERER} !^http://(.+\.)?trampolinereviewsonline\.com/ [NC]
    RewriteCond %{HTTP_REFERER} !^$
    #Replace /images/nohotlink.jpg with your "don't hotlink" image url
    RewriteRule .*\.(jpe?g|gif|bmp|png)$ /images/nohotlink.jpg [L]

    3) Could the domain mapping plugin settings be causing this? I have options 1, 3 and 4 selected.

    Thanks for your help

  4. What I'm trying to sort out is if this worked as domain.com/site but NOT as mappeddomain.com, or if it worked as mappeddomain.com and then suddenly stopped :)

    Knowing when is important.

  5. gtataje
    Member
    Posted 2 years ago #

    I installed a fresh copy of wp multi-site, created the sites and mapped them on 01-AUG-2012. They both worked as domain.com/site and as mappeddomain.com. They worked for a bit and then just stopped. Don't know exactly how many hours they did work, but the day after I started getting the redirect loop error message.

    Hope this helps (fingers crossed)

  6. Okay, so they worked as mapped domains and then suddenly stopped :) That's the important bit.

    Try checking option #2 in the WP Domain Mapping page.

    Basic rule: Always check stuff at each stage of the process. Make sure the subsites work before you map a domain and so on ;)

  7. gtataje
    Member
    Posted 2 years ago #

    Really appreciate the tips about checking stuff at each stage. Makes sense.

    Just marked option 2 (as well as 1, 3 and 4), but nothing changed. Also tried leaving just option 2 marked, but nothing's changed so far.

  8. gtataje
    Member
    Posted 2 years ago #

    I tried typing the domains in all lower case in the Domain Mapping page, and now switch-marketing.com is working! However trampolinereviewsonline.com is not. I'm really stumped! Do you have any idea why this is?

    Thanks

  9. gtataje
    Member
    Posted 2 years ago #

    Hi Mika, just wanted to say thanks for your help. I cleared the cache and now the other site is working too!

Topic Closed

This topic has been closed to new replies.

About this Topic