WordPress.org

Ready to get started?Download WordPress

Forums

Custom Sidebars
[resolved] Error (5 posts)

  1. Willem-Siebe
    Member
    Posted 10 months ago #

    Hi,

    Do you know why I get this error on top of my page?

    Notice: Undefined index: defaults in /www/web2738/www.caesarsbeauty.nl/http/wp-content/plugins/custom-sidebars/customsidebars.php on line 506 Call Stack: 0.0001 632344 1. {main}() /www/web2738/www.caesarsbeauty.nl/http/index.php:0 0.0002 637888 2. require('/www/web2738/www.caesarsbeauty.nl/http/wp-blog-header.php') /www/web2738/www.caesarsbeauty.nl/http/index.php:17 0.6101 84171872 3. require_once('/www/web2738/www.caesarsbeauty.nl/http/wp-includes/template-loader.php') /www/web2738/www.caesarsbeauty.nl/http/wp-blog-header.php:16 0.6138 84429320 4. include('/www/web2738/www.caesarsbeauty.nl/http/wp-content/themes/toolset-bootstrap/page.php') /www/web2738/www.caesarsbeauty.nl/http/wp-includes/template-loader.php:47 0.6138 84429320 5. get_header() /www/web2738/www.caesarsbeauty.nl/http/wp-content/themes/toolset-bootstrap/page.php:6 0.6138 84430328 6. locate_template() /www/web2738/www.caesarsbeauty.nl/http/wp-includes/general-template.php:35 0.6138 84430632 7. load_template() /www/web2738/www.caesarsbeauty.nl/http/wp-includes/template.php:383 0.6141 84512776 8. require_once('/www/web2738/www.caesarsbeauty.nl/http/wp-content/themes/toolset-bootstrap-child/header.php') /www/web2738/www.caesarsbeauty.nl/http/wp-includes/template.php:407 0.6171 84535664 9. wp_head() /www/web2738/www.caesarsbeauty.nl/http/wp-content/themes/toolset-bootstrap-child/header.php:24 0.6171 84535800 10. do_action() /www/web2738/www.caesarsbeauty.nl/http/wp-includes/general-template.php:1607 2.3593 105329984 11. call_user_func_array() /www/web2738/www.caesarsbeauty.nl/http/wp-includes/plugin.php:406 2.3593 105330040 12. CustomSidebars->replaceSidebars() /www/web2738/www.caesarsbeauty.nl/http/wp-includes/plugin.php:0 2.3593 105331264 13. CustomSidebars->getDefaultReplacements() /www/web2738/www.caesarsbeauty.nl/http/wp-content/plugins/custom-sidebars/customsidebars.php:89

    http://wordpress.org/plugins/custom-sidebars/

  2. Hi there @Willem-Siebe,

    I hope your well today, thanks for your question!

    I have just checked this on my test install to try and replicate and haven't been able to.

    They are just notices and nothing to worry about, do you have WP_DEBUG set to true in your wp-config.php ?

    define( 'WP_DEBUG', true );

    If so just change true to false, or you disable display notices in your php_ini file on your server :)

    Thanks!

    Kind Regards
    Jack.

  3. Willem-Siebe
    Member
    Posted 9 months ago #

    Hi Jack,

    In the changelog I did see you fixed a lot of errors with debug mode 'on', and to be honest, everything dissapeared, some of this you can see in this video where i update the plugin.

    However, in the backend when I go to widgets , I can't make or open sidebars to edit widgets etc, so I disabled plugin again see http://screencast.com/t/QiQoJSO1

  4. Hi there @Willem-Siebe

    Greetings, sorry about the delay.

    Which plugin and WordPress version are you using?

    Could you deactivate all other plugins and see if you still get the same issue? Then re-enable one by one till the issue reappears.

    I've tested on a fresh install and can't replicate I'm afraid.

    Thank you!

    Kind Regards
    Jack.

  5. Willem-Siebe
    Member
    Posted 8 months ago #

    Hi,

    Well, in the video you see the problem is there.
    Although I did not change anything to the website, this problem is gone also. So I mark this as resolved.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.