WordPress.org

Ready to get started?Download WordPress

Forums

erratic textarea width in admin page (8 posts)

  1. yukie
    Member
    Posted 10 years ago #

    in various places, such as the template editor (or even this form where i'm typing this post), the textarea suddenly goes berserk and extends its width when i begin typing something...i guess this must be some kind of IE bug? (i'm on an IE6 right now, and haven't checked it yet with mozilla)
    i know i could always just fix the size of the textarea in the css but perhaps the default install should consider this? since a lot of people use IE no matter how we complain. :)

  2. NuclearMoose
    Member
    Posted 10 years ago #

    yukie,
    Your post is a bit confusing because it seems as though you are talking about both this forum and your site. Is this the case? The default install does work in IE, BTW. Perhaps you have some corrupted files?

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    I am getting the same problem, even this posting box, it does kind of go erratic.

  4. Anonymous
    Unregistered
    Posted 10 years ago #

    Well I just did some searched on it but it keeps referring me back to the css file telling me to edit the commentbox width to less than 75% but how would that make a difference? After all I am getting the problem on this site as well. Sorry if Im sounding confusing

  5. Sam
    Member
    Posted 9 years ago #

    I've just discovered the same problem, Doesn't happen in Firefox, but someone using Avant, just pointed it out to me, and now i've noticed it in IE6...

  6. Muffinboy
    Member
    Posted 9 years ago #

    I confirm this behavior on the forums. This indeed happens with IE6 and IE5.5 on WinXP SP1.
    The forums go wild in IE5 with huuuuge white spaces appearing and the textarea is already very very wide in IE5, but doesn't resize when you start typing in it.
    I can't confirm it for the standard WP install, as I just ripped out all the css for my test site.

  7. knuckles
    Member
    Posted 9 years ago #

    I'm throwing my hat in the ring to say I too have the same problem. For my blog, i changed the value in the wp-comments.php file for textarea name="comment", rows="4" to rows="10 to increase the height of the text box. I then changed the value in wp-layout.css file for #commentform textarea from width= 75% to width: 600px so that the width of the text box will remain a fixed width. This has solved the problem on my blog.

  8. sirokai
    Member
    Posted 8 years ago #

    I found this problem too. Seems to be an IE bug for sure. I have my comment forms on my WordPress theme set to 80%, so to keep that setting in the good browsers, I apply a width of 450px specifically to IE, like so:

    #commentform textarea { width:80%; }

    * html #commentform textarea { width:450px; }

    What comes after " * html " is only seen by IE. Works great!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.