WordPress.org

Ready to get started?Download WordPress

Forums

EP Admin Messages
[resolved] ".ep-config.json" does not contain valid JSON. (9 posts)

  1. freakzone89
    Member
    Posted 11 months ago #

    Hey guys,

    your plugin provides exactly the feature i was looking for, but how do i set it up?

    What i've done is, to create a .ep-config.json file to the folder of my child-theme. I inserted the lines of code from your ep-config-example.json and now the message on my dashboard is:

    EP Admin Messages: Config file ".ep-config.json" does not contain valid JSON.

    Do i have to add something like <?php at the beginning and ?> at the end? Hope you can help me.

    Cheers

    http://wordpress.org/plugins/ep-admin-messages/

  2. Pär Thernström
    Member
    Plugin Author

    Posted 11 months ago #

    hm, if the contents in your json is exactly the same as the example file then it should work. could we try a more minimal examle. what if you paste the contents of this file:

    https://gist.github.com/anonymous/6605760

  3. freakzone89
    Member
    Posted 11 months ago #

    as i added this code, it works!

  4. freakzone89
    Member
    Posted 11 months ago #

    i tried another piece of code and added

    {
      "messages": [
        {
          "message": "Test.",
          "user_role": "admin",
          "location": "dashboard"
        },
      ]
    }

    and now it's also:

    EP Admin Messages: Config file ".ep-config.json" does not contain valid JSON.

  5. freakzone89
    Member
    Posted 11 months ago #

    got it!

    it seems to be the arrangement. i inserted it this way:

    {
    "messages": [
    {
    "message": "This message is visible on all screens, for all users.",
    "location": "post_type:event, post_type:post"
    }
    ]
    }

    and all works fine

  6. freakzone89
    Member
    Posted 11 months ago #

    Another issue is, that the plugin can't deal with "ä,ö,ü" letters. So i replaced them in the texts and it works.

  7. Pär Thernström
    Member
    Plugin Author

    Posted 11 months ago #

    hm, have you saved the json-file in utf-8? i'm pretty sure it works with åäö etc (i'm swedish myself and we have lots and lots of those funky characters!)

  8. freakzone89
    Member
    Posted 11 months ago #

    i don't know if it's in utf-8, but i only edited it in notepad and i'd say there isn't a change in the file-format.

  9. Pär Thernström
    Member
    Plugin Author

    Posted 11 months ago #

    Ok. Thanks for the info, I'll double-check it on my end.

Reply

You must log in to post.

About this Plugin

About this Topic