WordPress.org

Ready to get started?Download WordPress

Forums

Enraged (6 posts)

  1. bl4h
    Member
    Posted 7 years ago #

    I want to insert a flash object, but wordpress insists on converting & to &amp

    I know, this is proper xhtml, but it does not work under opera or firefox when used in embed/object with flash.

    There should be an option, to stop wordpress from parsing your input. No matter what it contains.

    I cant find this option anywhere

  2. whooami
    Member
    Posted 7 years ago #

    I can tell you a very quick _possible_ fix for this will take a little editing:

    open up wp-includes/kses.php

    locate this line:

    $string = str_replace('&', '&', $string);

    beneath it put:
    $string = str_replace('sipsip', '%26', $string);

    Save the file.

    Where sipsip can be some word youre never going to use except for when you want the correct encoding. You will obviously need to do your own replacing of & with sipsip inside your post.

    that should work, its the proper encoding, its just a matter of whether or not flash will understand it. Give it a shot, ill be curious as to the result.

  3. whooami
    Member
    Posted 7 years ago #

    There should be an option, to stop wordpress from parsing your input. No matter what it contains.

    There is that option, and its called disabling wpautop. There are several plugins that do this, or you can just comment it out of kses.php.

    http://wordpress.org/search/disable+wpautop?forums=1
    http://wordpress.org/support/topic/20608?replies=10
    http://www.google.com/search?hl=en&q=disable+wpautop&btnG=Google+Search

  4. bl4h
    Member
    Posted 7 years ago #

    Hmm did that, but for some reason its not converting sipsip. I think its run through some other functions before it gets to that one, to ensure its an &code that worpress is interested in messing with.

    Also, I making a static html file using %26. Flash doesnt understand %26 unfortunatly :|

    In IE, &amp works fine in flash embed, but it doesnt work in firefox or opera. It seems to only work with &

    Really, i dont know which of the 3 is wrong here :)

    Thanks for the try though

  5. Chris_K
    Member
    Posted 7 years ago #

    Or just turn off the wysiwyg editor.
    Users -> Your Profile, bottom option.

    Or use one of the many plugins.

  6. bl4h
    Member
    Posted 7 years ago #

    Ok, my mistake. It doesnt convert it to &amp

    it converts & to &#038 ...which does not work

    HandySolo, that doesnt work. It still converts input

    Ill find some pluggins and browse the urls posted by whomai.
    thanks for the help

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags