WordPress.org

Ready to get started?Download WordPress

Forums

Enough with smaller characters (friendly rant) (4 posts)

  1. Sabinou
    Member
    Posted 2 years ago #

    Hello,

    I'm under the impression that the fonts are now a bit smaller in the wordpress Visual Editor.
    (I'm not asking for help, just ranting a little bit with hopes to convince you :) )

    Of course it may depend on "local conditions", settings on my home computer.
    This friendly rant is posted in case I am not mistaken and the Visual Editor actually switched to smaller fonts displayed with wordpress 3.3

    To sum it up : enough with the fonts becoming smaller and smaller ! It's a real hindrance that we have to zoom in, more and more, for visual comfort. Small doesn't mean hype or techie friendly, it means "hard to see".

    Making texts smaller goes against the evolution of the internet users' needs. As time passes we all buy larger and larger monitors and we can, at least, finally, un-stick our noses from the surface of our monitors, and sit at a comfortable distance from our monitors.
    But, while we get farer and farer from the screens, the texts in several interfaces become smaller, that doesn't make much sense, and forces us to adjust more and more the zoom level in several websites (recommendation, BTW, the Firefox extension called "default zoom level", it remembers the per-site settings.)
    (The users of cellular phones and of tablets are still a small minority.)

    See what I mean ?
    In this regard, making the texts smaller in the Visual Editor goes against the natural flow of internet uses :)
    How about making it larger with wordpress 3.4 ? ;)

    (and there's still the possibility that it's only happening on my computer, and then, sorry to have wasted your time)

  2. I don't believe the font size changed between 3.2 and 3.3 (I did a quick scan of trac and didn't see anything).

    Mind you, the size on your visual editor can be caused by your theme. What theme are you using?

  3. Sabinou
    Member
    Posted 2 years ago #

    I'm using a super old Andreas theme, maybe it interacts differently with the newest wordpress, go figure.

    Oh well, I'm reassured if I'm the only person affected by the problem.

    I'd adjusted my system DPI size, my default Firefox fonts, so it may also be that other side of things causing the problem.
    Local conditions.

    It's better if other persons are unaffected, thanks for the reply Ipstenu !

  4. Plonk this is your theme's functions.php

    After the very top <?php, create a new line and paste the following code in, then save.

    add_action( 'admin_print_styles-post.php', 'my_admin_css' );
    add_action( 'admin_print_styles-post-new.php', 'my_admin_css' );
    function my_admin_css() {
    	?>
    	<style type="text/css">
    	#editorcontainer textarea#content { font-size:130%!important }
    	</style>
    	<?php
    }

    The function will print out the additional CSS on the pages where you write posts only (so it's not loading on every admin page), and applies a font size increase to 130%, adjust as required.

Topic Closed

This topic has been closed to new replies.

About this Topic