WordPress.org

Ready to get started?Download WordPress

Forums

Enhanced Views and SQL error (4 posts)

  1. solutionsphp
    Member
    Posted 7 years ago #

    The Cold Forged Enhanced Views plugin generates a SQL error on my Manage pages because the WP db structure has changed:

    WordPress database error: [Unknown column 'user_level' in 'where clause']
    SELECT * FROM wp_users WHERE user_level > 0 ORDER BY user_nickname

    Can someone recommend the correct SQL query to replace that one?

  2. Kafkaesqui

    Posted 7 years ago #

    What version of the plugin are you running? I don't see that particular query in 0.3 (nor can I seem to generate errors in WP 2.1 with it).

    EDIT: Ah, nevermind. 0.4 appears to have it. I can't suggest a replacement query offhand, mainly because user_level and nickname values are now tucked into the usermeta table.

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    That bit of code is in version 0.4 of the plugin, however, the plugin's webpage clearly states that the plugin does not work with WordPress 2.0. I assume it also would not work with 2.1.

    The user level column has been gone ever since going to 2.0, in favor of the user roles instead. User "levels" are now part of the usermeta table.

    So I assume that making the plugin work would be a larger matter than just fixing a couple queries.

  4. solutionsphp
    Member
    Posted 7 years ago #

    Thanks for your replies. I am running this v 0.3 of this plugin on WP 2.0.7. The only problem I have is that the User drop down doesn't function because of the change to the WP DB. I'll take a look at 0.4 to see if I can correct that query and get it to work!

    UPDATE: These might be interesting to anyone looking for the same info:
    http://www.stilglog.com/wordpress-plugins/enhanced-post-views/
    http://www.stilglog.com/wordpress-plugins/manage-me/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.